Results 1 to 9 of 9
  1. #1

    Join Date
    Sep 2011
    Location
    Boca Raton, FL
    Posts
    22

    HELP Loud Rattle in Water

    I have a 08 RXPX with 90 HRS never changed the SC Washers. I was riding the other day on the lake and i heard and really loud rattle coming from the back. I went to shore and put it right on the trailer and try to start it to see if i can find where its comming from and it didnt rattle. I then put it back into the water on the trailer at idle and it started to rattle again. its very loud and i scared to start it again. i don't want to cause more damage what do you guys think it can be
    Thank you


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Check the charger & the jet pump..... it's more than likely one or the other. Hopefully is in your pump!

    That chargers about ready for a rebuild anyway, so you might as well pull it. The 08 washers didn't need to be changed out.

  3. #3
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Possible broken baffle in water box.

    Check jet pump as BD stated.

  4. #4
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by skoepp View Post
    Possible broken baffle in water box.
    Or muffler bearing .....

  5. #5
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Lol

  6. #6
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    also check the anode on the pump .. Mine mysteriously vanished! I think Bd stole it. they will rattle when loose.

  7. #7
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by Sturm215 View Post
    Mine mysteriously vanished! I think Bd stole it.
    Sorry bout that, one of mine fell off..... didn't think you'd notice it missing. Hey..... look at it this way, at least yours doesn't rattle anymore

  8. #8
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    Quote Originally Posted by BigDaddyRXP View Post
    Sorry bout that, one of mine fell off..... didn't think you'd notice it missing. Hey..... look at it this way, at least yours doesn't rattle anymore
    thats ok i found a new 2012 one in my pocket from sunday.. weird how that worked out.

  9. #9

    Join Date
    Sep 2011
    Location
    Boca Raton, FL
    Posts
    22
    Thanks Guys it turned out to be the Pump Bearing it shattered

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. MSX Drags Tube Rope in Water - Help
    By Koodat in forum MSX/Matrix
    Replies: 3
    Last Post: 06-15-2010, 12:42 PM
  2. Engine keeps sucking in water. HELP
    By DimaBoyee in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 04-10-2009, 07:15 PM
  3. Help me diagnose why water is getting in the cylinders
    By MPower in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-24-2008, 06:52 PM
  4. Help! GIO and now water in oil!!!
    By fairlanex in forum Kawasaki PWC Performance (4-stroke)
    Replies: 13
    Last Post: 05-23-2008, 09:42 AM
  5. Help!! Towing 96 xp in water
    By smitch in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 08-13-2007, 01:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •