Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    blacktop's Avatar
    Join Date
    Mar 2013
    Location
    South Florida
    Posts
    51

    99 GTX Limited Dies At full Throttle

    Hey there, I've been working on this thing for more than a year and it still doesn't run right. To save you guys time, yes carbs have been rebuilt and grey lines are out, it used to bog at midrange and run great at full throttle, it had r&d flame arrestors, changed jets to low 167.5 and high 85, that got rid of mid range bog. now after about 10 minutes at full throttle it just dies, i can fire it right back up no problems. raves are cleaned, stattor was rebuilt, regulator charges battery right, spark is good, it runs 50:1 premix with 87 octane. i was thinking it might be a too rich/lean condition? can that cause this symptom? low speed are out at 1.5 and highs at .5.any help is appreciated thank you


  2. #2

    Join Date
    Mar 2006
    Posts
    1,833
    +1
    119
    10 minutes at full throttle you say on a 951 and it is shutting off on you?

  3. #3
    rhyne717xp's Avatar
    Join Date
    Apr 2011
    Location
    Rocky Top Tennessee
    Posts
    304
    +1
    7
    Dieing at WOT is never good, sounds like a mild seizure. Compression test?

  4. #4
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,523
    +1
    1,270
    fuel starvation, lack of proper orifice on fuel return line which lets the carb dump too much fuel during high flow demands.

    The fuel return outlet on a 951 and I believe this ski is a 951 is tiny. if often fools folks who had had fuel line issues that it's restricted and they often enlarge the orifice to 3-10 x it's normal size as it just doesn't seem to be "right" Last season I had two that had been snapped off and fitted with a full flow nipple ( it's a rather expensive bit to buy at a dealer) I was surprised how restricted the outlet was.

    I was fooled myself for a bit, I was lucky I didn't lunch the carb/ Hate those pressed plastic fittings they use. real junk

    anyhow..easiest way to tell would be to pull the plugs when it craps..if they are too white bazinga..the line isn't restricted enough.

    Somebody please chime in on that entire "use a carb jet in the return line" business. I don't deal with a whole lot of mods but adding additional restriction in the return line is an obvious next step for this problem.

    You could have an air leak in the fuel system, typically at the selector valve..but that's not as easy to deal with as the return line biz. SBT Sells a valve for like $25..seadoo oem a little more then that. I don't like trying to clean em when they are gummed up..the orings often leak after that

    That's assuming that the 951, like lots of other seadoos specifies a full closed high speed needle. Might be too rich if it's open. Replaced the rubber bits and needle seat I trust? I would think after dealing with this for so long you've gone over the pop off pressure and all the rest of things involved.

    with your changes, did you do some plug chops to see how the mixture was?..951 is an expensive ski to blow up.

    your complete description was good. Check the plugs..they are talking to you.

  5. #5
    SURFnTURF's Avatar
    Join Date
    May 2007
    Location
    Australia
    Posts
    878
    +1
    11
    Have you inspected the rubber grommets (5) in the fuel pump and make sure they dont have a tiny hole in the centre of them
    Look at the 2 clear check valves (4) on the pump ,make sure they are seated all around the perimeter and dont have any kinks in them
    Have you got (6) and (7) dampers in the correct way as they can be reversed easily
    Check fuel filter screens for blockage
    You may need to go through the carbs again and blow/wash out in fresh fuel and all parts.
    I think its fuel delivery related ,hope you haven't squeaked a piston/ring when it has dies at wot ?
    Attached Files Attached Files

  6. #6

    Join Date
    Dec 2012
    Location
    Puerto rico
    Posts
    17
    Quote Originally Posted by blacktop View Post
    Hey there, I've been working on this thing for more than a year and it still doesn't run right. To save you guys time, yes carbs have been rebuilt and grey lines are out, it used to bog at midrange and run great at full throttle, it had r&d flame arrestors, changed jets to low 167.5 and high 85, that got rid of mid range bog. now after about 10 minutes at full throttle it just dies, i can fire it right back up no problems. raves are cleaned, stattor was rebuilt, regulator charges battery right, spark is good, it runs 50:1 premix with 87 octane. i was thinking it might be a too rich/lean condition? can that cause this symptom? low speed are out at 1.5 and highs at .5.any help is appreciated thank you

    I had tis same situation and I kept tinking I had fuel problems.It ended being an electrical issue.The nut on the starter relay that holds the batterie postive wire and the fuse holder toguether was loose,so at higher rpms the mpem was runing out of power becuse of the contact failure.check all your power suply to your mpem.

  7. #7
    blacktop's Avatar
    Join Date
    Mar 2013
    Location
    South Florida
    Posts
    51
    thanks for all the responses, yes the pop off was set intune for the flame arrestors, coil are clean ut will deff double check them and after what i read im leaning towards the open hi speed screws, will close them all the way, and keep lows at 1 1/2, as soon as i get time ill take it on the lake and ill report back on findings, thank you.

  8. #8
    20 feet Boy's Avatar
    Join Date
    Jul 2010
    Location
    Bend OR
    Posts
    1,257
    +1
    1
    check fuel pick up tube for cracks or a loose fuel hoses. It runs out of fuel on top end then starts sucking air.

  9. #9
    blacktop's Avatar
    Join Date
    Mar 2013
    Location
    South Florida
    Posts
    51
    Checked air lines and electrical, didn't get it on the lake yet, but what do you guys think about these jetting specs?
    Lows 167.5 at 1&1/2 open
    Highs 85 at 1/2 open
    Stock 2.0 N&S
    65 gram springs
    R&D flame arrestors
    Premix 50:1 in 87 octane

    Does that look lean or rich?
    I was leaning towards lean since it fires right back and I was going to open the highs to 3/4 and see if it runs a bit better

  10. #10
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,523
    +1
    1,270
    I guess you skimmed over my message.

    try reading it in full

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help please!!! 2011 Sea Doo speedster Dies at full throttle
    By Benevengajb in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 04-07-2016, 11:08 AM
  2. 94 GTX now power at full throttle
    By luna_azul in forum 2-Stroke Performance
    Replies: 10
    Last Post: 09-20-2014, 11:10 PM
  3. 1997 sl 700 dies at full throttle
    By kaotic1 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 08-04-2014, 02:07 PM
  4. Polaris 1996 slt 780 Dies at full throttle
    By Water Toy in forum Polaris PWC Performance
    Replies: 21
    Last Post: 08-02-2012, 07:35 PM
  5. 785 died at full throttle
    By killcraft in forum Polaris PWC Performance
    Replies: 5
    Last Post: 06-09-2011, 02:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •