Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    09' vx110 warning light

    First time poster. Just bought a 09' vx110 has 385 hrs. was rebuilt by a ski shop 10 hrs. ago and it was a rental.
    First ride everything was fine but, only topped out at 43 on the GPS. Is that normal?
    Second time out warning light came on after 20 min. When I started getting in and out of throttle, shut it off and checked oil, fired up no light. 20 min. Later comes back on I keep riding to launch and it goes off.
    Also it fires up very easily when cold but it takes a while for it to crank when you shut it off and try to crank it back up hot. Sometimes i can ride for an hour and no light other time i can crank it up and the light comes right on. Water pump is working. Display is showing engine when warning comes on. At WOT I can hear a slight hesitation in and out in the engine. Where do I start?


  2. #2
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Stop riding it till you figure it out, its not going to fix itself while you are riding it, take it to a shop and have them read the code......

  3. #3
    Like I said above it doesn't come on right away. Can they read it without the warning light on?

  4. #4
    Orange FZS's Avatar
    Join Date
    Aug 2012
    Location
    Melbourne
    Posts
    280
    +1
    43
    yeah they can read the fault code without the warning light being on and exactly what hours it occured at.
    Joel

  5. #5

    Join Date
    Jan 2012
    Location
    SoCal
    Posts
    111
    +1
    3
    Out of curiosity, do you get water out of the pilot outlet on the left side of the hull while it's running?

    Also, when the warning light comes on you will also see a symbol pop up below the speedo indicating either "check engine", engine temp, oil pressure, or low fuel. Any idea which one comes on? That will let you know if the problem is something that you can investigate further on your own or if you just need to have a shop look at it. If you're not sure then I wouldn't risk it, have a shop read the codes. If the problem is engine temp or oil pressure then you risk doing some major damage that could be avoided by having it properly diagnosed.

  6. #6
    Yes, there is water coming out of pilot hole.
    The indicator is showing a picture of an engine.
    I'm looking for someone local to run the code.
    I've only put 2 hrs on it all together it idles smooth, accelerates fine just only tops out at 43 mph. Is that normal for this ski or could it be from whatever is causing the warning.

  7. #7
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    On GPS it should be a low 50 mph ski....if you are reading the speedo they are known to off......again you need to find out what the problem is before you take it out again....any Yamaha Dealer should be able to pull the codes......

  8. #8
    infamous's Avatar
    Join Date
    Oct 2010
    Location
    Long Island, NY
    Posts
    2,036
    +1
    336
    Did you buy it from the shop that did the rebuild? Any kind of warranty on their work? That's where I would start....

  9. #9

    Join Date
    Jan 2012
    Location
    SoCal
    Posts
    111
    +1
    3
    Well, being a check engine light is better than overheating or low oil pressure, IMO, as that usually just means a problem with a sensor or connection. It could be running in a default fuel/timing map to avoid damage, resulting in the low speed, so with any luck the code will point to a faulty sensor or connection and you'll be back on your way at full speed in no time.

    I do find it odd that the engine was rebuilt with those kind of hours, any idea what was wrong that caused them to do the rebuild? Any sort of receipts for the work? Good luck.

  10. #10
    As to only going 43 MPH-Is it in L-mode? Did you get the security remote? Also agree with everyone else figure out the code before possibly causing damage. I believe if you hold down the mode button for 8 seconds it will give you a code and you can research from there.
    Best of luck.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. vx110 warning light and engine warning sign showing
    By KyleP in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 09-22-2011, 05:38 PM
  2. red warning light
    By wavehummer in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-23-2007, 08:53 PM
  3. Installed D-Plate, now my warning light is blinking
    By future_cpa27 in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 07-15-2007, 05:52 PM
  4. 04 3D warning light
    By germie in forum 2-Stroke Performance
    Replies: 0
    Last Post: 05-06-2007, 04:36 PM
  5. Warning light coming on rr ecu
    By Chezzy in forum 4-Tec Performance
    Replies: 7
    Last Post: 04-19-2006, 08:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •