Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 34
  1. #1

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308

    2001 Genesis Ficht DI, had poor throttle response, now no start

    I have a 2001 genesis 1200 di that will start up and idle but as soon as I touch the throttle it boggs out like the injectors aren't sending more fuel I have replaced the tps and it did not fix the problem
    Last edited by K447; 04-29-2013 at 10:11 AM.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,275
    Sort answer, the EMM probably needs repair.

    BUT FIRST, make sure the correct spark plugs are installed, and fresh. NGK PZFR6H, no substitues.

    Longer answer, check the sensors for correct ohms. CPS, air temp, exhaust temp. Also verify the ignition coils are well grounded.

    Check the White/Red wire for correct voltage with engine running, all injectors plugged in. Should be right around 45 volts and stable as RPM changes.

    My signature link has more details and related info.

  3. #3

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    Every thing is grounded and I have 28 psi for fuel pressure

  4. #4
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,523
    +1
    1,270
    so was this a "wtf" moment or was there some other information that might be helpful to know....?

    of course all that other "stuff" needs to be confirmed as in order also

    system charging voltage @ idle?

  5. #5

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    Okay sorry I like that last post I do not know how to test the sensors ohms but the spark plugs a new the Ngk platinum 20$ each. I checked the voltage at each injector on the red and white and it was in between 45 and 50 volts on each injector. Does that mean my emm is good? What's next?

  6. #6

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    And the battery is at 13.2 off and 14.3 when engine is at idle

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,589
    +1
    1,275
    Quote Originally Posted by jetski4ever View Post
    the spark plugs a new the Ngk platinum 20$ each...
    And the correct part number?

  8. #8
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,523
    +1
    1,270
    Quote Originally Posted by K447 View Post
    And the correct part number?
    for $20 a crack they better be the right one!

    next step//move the crank position sensor ( on the stator housing, one allen socket bolt..clean the end..if it's damaged or has metal chips on it..could be the problem. remove and clean if needed. If it needed to be cleaned..you _could_ be done

    give you a 1 on 7 of that being the case.

    tell us about this replacement tps....did you have a look at the connector end...sometime a little squeezing is called for.

  9. #9

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    Yup the correct plugs

  10. #10

    Join Date
    Apr 2012
    Location
    Southern California
    Posts
    308
    OkAy im lost I cleaned the crank position sensor and no change I'm lost. I called di tech and the were very knowledgeable but they had no idea what it could be but had advised me to send the emm and injectors in to be checked is their any chance it could be the emm

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts 2001 1200 Ficht DI engine parts
    By rr44red in forum Polaris Classifieds
    Replies: 0
    Last Post: 08-27-2014, 06:03 PM
  2. 2001 Genesis Ficht poor performance
    By WaveChaser in forum Polaris Open Discussion
    Replies: 53
    Last Post: 09-13-2010, 09:54 AM
  3. 2001 Genesis FICHT fuel injector question..
    By polarisrider007 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 08-11-2010, 10:47 PM
  4. Replies: 1
    Last Post: 06-19-2010, 04:36 PM
  5. 95 SL750 Poor Throttle Response
    By christian79 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 08-14-2007, 11:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •