Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
  1. #1

    2000 seadoo gtx di only revs to 4800 rpm please help!!!!

    Hey guys, I have a 2000 gtx di that went in limp mode on and off at the end of last summer. It starts fine and then u rev it up and the tops is only 4800 rpm it will reach.It seems like carb. 2 stroke loading up and needs cleaned out.It idles at 1450 rpm and reaches 4800 rpm unless i hold the rave valves up then i can reach 4950-5050 rpm.WOT it seems like the rev limiter is holder it back.I checked the ravs,seals and orings,Good.Spark plugs and fire are,Good.Checked the 4" exhaust tube that goes to muffler or baffle for it collasping wen i rev it up,Good.I have a 02 gtx di that i switched the sensor's on the side of throttle bodys and the ones on the rubber boot underneath throttle bodys and it ran the same.I even switched the MPEM from 02 to 00 using the 02 lanyard with it and it ran the same.Also i put a new oem rectifier on it and it ran the same.Wen i had caps off of ravs, i was holding valves up while letting it run and it wanted to pull them out of my hands, back down.Fuel pressure was round 40 -45 wen u put lanyard on, then it would go to 110psi wen u started and rev it up.Does the ski need the codes reset since i put on the new rectifier? If so, will it reset itself by unhooking the battery or any other way? I could use any ideas,help, suggestions or etc.Im thinking of putting ski up for sale and didnt wanna put alot n it for a scanner tool to check it if i didnt have too.But i will do wat ever i need.Thanks Guys!


  2. #2
    AndinoWatercraft's Avatar
    Join Date
    Feb 2008
    Location
    Puerto Rico
    Posts
    306
    +1
    4
    How's your engine compression??? Also have you inspected the air compressor and it's lines for any obstruction. They can get moisted inside . You've measured the voltage (charge test ) to discard the stator ?? Remove the throttle bodys and intakes. Inspect the reed valves to see if any are bent.

  3. #3
    compression is 135 per cylinder.Reeds look fine.How do u check air compressor? Wheres is located at?Where and how to check voltage on stator,wat wires do i need to check?I forgot to mentioned that the mainentance light is on and it flashes maint across readout.

  4. #4
    i also put on new ignition coils too! That wasnt the problem. With the positive hooked to the battery, i go to hook the negitive up and it has a little spark to it.I c no bad hoses or anything like that. If i unhook one of the main plugs goin to the mpem it stops the little spark. Any ideas????

  5. #5
    wat part of the electrical system stores the codes ,cause i switched out the mpem with another and the ski done the same thing ???

  6. #6
    It is very likely you have a serious fault which is putting the MPEM into limp mode, that is why you are limited to 5000 RPM. You said the MAINT is on, it is either a fault causing this or the maintenance reminder function.

    To confirm, 1st try resetting your maintenance counter by waking up the MPEM by putting the key on, then holding the SET button down for more than 2 seconds. After you do this, if you still have the MAINT warning, then this confirms you have an active fault. To determine what the problem is, you must either take the ski to a dealer to read the fault codes, or buy a Candoopro system and do it yourself. You will be wasting your time if you don't do this.

  7. +1 by:


  8. #7
    Seadood, i tried holdin down set button for as much as 10 sec and then it ran same way.Wat could be the active fault?? i dont understand y it ran the same way after i switched out the mpem with a different one ????? i thought the mpem held all codes and etc??? Thanx man!

  9. #8

    Join Date
    Mar 2006
    Posts
    1,829
    +1
    119
    sounds like an air injector.

  10. +1 by:

    GGG

  11. #9
    Jim, u think maybe air injector? How do i go about checking the air injectors? Thanx man!

  12. #10
    Quote Originally Posted by motormadness View Post
    Seadood, i tried holdin down set button for as much as 10 sec and then it ran same way.Wat could be the active fault?? i dont understand y it ran the same way after i switched out the mpem with a different one ????? i thought the mpem held all codes and etc??? Thanx man!
    Did it still have the MAINT warning after this? (you didn't say; all you said is that it ran the same way...)

    If you still have the MAINT warning after what I told you to do, then you still have a fault that needs corrected before it will run right.

    There are a total of 13 Sensor/System conditions on a DI that will hold you in limp mode like you are seeing. There is no way you can even begin to know what to do until you scan the MPEM for faults like I told you to do. Until you know exactly what it is, you will waste your time and everyone elses time.

    Do not listen to guys that say things like "sounds like air injector". Like I said, there are 13 different things that could cause what you are seeing. Until you scan the MPEM, you are just guessing.

    Until Candoopro came out, the only way individuals and shops could work on DI's is to swap out parts until they found the offending item. The problem with this approach, besides being very expensive, is it wont work for intermittent harness or connector related problems.

    Stop right now, go pay a dealer to read out the codes (usually $100-200), or buy a Candoopro system ($400) and do it yourself and do it right. Note that if you pay a dealer to do it, it is often a 2 step process. On a DI, you need to clear out all fault counts first, then run the ski again until the problem occurs again to capture the fault. (yours seems to be a constant fault, so it should show up on the trailer when run again)

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Seadoo GTX DI wont go above 1450 RPMS
    By tjwj1 in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 08-18-2013, 12:47 AM
  2. 2000 Seadoo GTX DI wont rev above 4850 RPMS
    By tjwj1 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-05-2013, 06:31 PM
  3. 2000 Seadoo GTX DI - Free Flow Exhaust Question
    By MILIMITED00 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 01-16-2012, 11:32 AM
  4. Quick question... 2000 Seadoo GTX DI
    By MILIMITED00 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 04-04-2011, 10:29 AM
  5. WTB Needed Exhaust maniold for a 2000 seadoo gtx di mill edition
    By gvnitup in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 06-27-2010, 12:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •