Results 1 to 10 of 10
  1. #1
    pete71's Avatar
    Join Date
    Apr 2007
    Location
    AUSTRALIA(Melb)
    Posts
    685
    +1
    21

    Intake looks suspect ??

    Pulled the intake manifold today to fit riva flame arrester block off and noticed strange discoloration of the rear runner

    any guesses to what's caused this , ski has been running flawlessly
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	197 
Size:	73.7 KB 
ID:	298455  


  2. #2
    Sayers's Avatar
    Join Date
    Jul 2010
    Location
    Melbourne AUS
    Posts
    2,300
    +1
    134
    Is it oily?

  3. #3
    i hate my bipolar disorder its great
    Join Date
    Nov 2011
    Location
    Melbourne - Australia
    Posts
    432
    +1
    9
    why do you think it looks suspect?

  4. #4
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    No your ok... button her up your valves look great Ride on " Magic Pixie Dust"

  5. #5
    it has a white dust like substance on it

  6. #6
    Boost-A-Holic's Avatar
    Join Date
    Jul 2012
    Location
    Dallas, Texas, United States
    Posts
    1,173
    +1
    94
    Quote Originally Posted by winterstick View Post
    it has a white dust like substance on it
    saltwater/dried up salt residue??

  7. #7
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    If its running fine then don't stress ... It wasn't owned by a Melbourne under belly ? Lol

  8. #8
    pete71's Avatar
    Join Date
    Apr 2007
    Location
    AUSTRALIA(Melb)
    Posts
    685
    +1
    21
    Quote Originally Posted by cracker View Post
    why do you think it looks suspect?
    Cause all the other runners where all black this one has like a burnt white in it

  9. #9
    GasResearch-VT.SE's Avatar
    Join Date
    Nov 2012
    Location
    Melbourne, Australia
    Posts
    1,172
    +1
    207
    Do a leak down while intake is off, check if seats are worn or leaky injector

  10. #10
    actis's Avatar
    Join Date
    Mar 2013
    Location
    maryland and florida
    Posts
    142
    +1
    5
    it definitely went lean. i would think the only two things that would lean one cylinder but not the others would be a wiped cam lobe or bad injector.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Looking for good intake grate Genesis
    By Budman in forum Polaris PWC Performance
    Replies: 3
    Last Post: 06-07-2009, 08:23 PM
  2. looking for a top loader intake grate for GP1200 '98
    By mclarenGP1200 in forum Yamaha Classifieds
    Replies: 0
    Last Post: 03-08-2009, 12:23 PM
  3. Looking for stock R-12X intake grate
    By jmssikes in forum Honda Open Discussion
    Replies: 2
    Last Post: 09-09-2007, 06:25 PM
  4. Looking for a used intake grate
    By RiverRat19405 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-21-2007, 10:32 AM
  5. Looking for an R&D 62T intake manifold.
    By Boris in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 03-26-2007, 07:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •