Results 1 to 5 of 5
  1. #1

    pros I need help once again please

    where on a 1999 ultra 150 is the voltage regulator Unless thats it under the steel crossbar am waiting for new one to arrive it doesnt charge batt>Thanks>Marvin


  2. #2
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,184
    +1
    98
    Quote Originally Posted by mrjetskey View Post
    where on a 1999 ultra 150 is the voltage regulator Unless thats it under the steel crossbar am waiting for new one to arrive it doesnt charge batt>Thanks>Marvin
    Its in the AFT electrical box, along with the starter relay. It's the box at the back that the spark plug wires do NOT go to. Behind the Battery.

    Part # 21066-3715

  3. #3
    Thats only place I didnt look thinking only solenoid was in there I started to go in there but the side box looked more promising,I know that they almost always design pwc where regulator is always fairly close to battery ,Many thanks I really appreciate the quick reply,I have battery out so should be easy!!!

  4. #4
    first off many thanks I got the part # that you posted dealer tried to sell me the -3716 which wont work with this ski,once again many thanks!!>Marvin

  5. #5
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,184
    +1
    98
    Quote Originally Posted by mrjetskey View Post
    first off many thanks I got the part # that you posted dealer tried to sell me the -3716 which wont work with this ski,once again many thanks!!>Marvin
    Are your circuit breakers good, are you sure the stator is putting out volts to regulate?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Help Asap AGAIN
    By greens1098 in forum 4-Tec Performance
    Replies: 11
    Last Post: 04-07-2010, 12:45 PM
  2. Pros, I need Help with overheating sl780 issues...
    By JGringo in forum Polaris Open Discussion
    Replies: 19
    Last Post: 03-31-2010, 12:27 PM
  3. AutoMeter Pro-Comp *Need Help*
    By XtoSHO in forum 4-Tec Performance
    Replies: 7
    Last Post: 03-04-2010, 09:24 AM
  4. Need help with idle. please please
    By MB VIP in forum Polaris PWC Performance
    Replies: 9
    Last Post: 11-03-2009, 01:01 PM
  5. Help me again please!!!
    By Great_Outdoors_5911 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-30-2007, 12:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •