Results 1 to 5 of 5
  1. #1

    Join Date
    Apr 2013
    Location
    werribee vic australia
    Posts
    2

    Cool 1992 3 cyl Polaris, blue Fuji engine

    hi guys im new to the jetski wold i got me a polaris in bits got it together and no spark. all wiring was in a box motor was out.

    its all together turnes over but no spark had a little smoke from a black wire in power box "hope thats all it was"

    any wiring diagrams i can coppy off somone by chance? id like to get it running.

    kind regards stuie


  2. #2
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    Welcome to the hulk, smoke coming from the electrical box, is not a good thing, possiblity the Stator is fried or the CDI or even the circuit board, open the E box up and start checking things out.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Welcome

    Smoke from a Black wire - my guess is that the battery post shorted to the electrical box shell. There is supposed to be a plastic battery cover, and it is important that the battery NOT touch the electrical box.

    See my signature links for some info and common issues regarding the blue Fuji engines.

    Disconnect the battery, then check every Black wire. My guess is that the black wire running from the electrical box to the magneto stator at the front of the engine has been toasted. Often some of the thin black wires inside the electrical box also get burned.

  4. #4

    Join Date
    Apr 2013
    Location
    werribee vic australia
    Posts
    2
    thanks guys, i dont know whear the box was suposeto go so i did a temp fix to the hull top left rear top of muffler fr time being. now ive red a bit of info i now no whear it goes "lol" is thear any way i can get a fue pages from a manuale posted of emaild to me so i no egsakly whear theas wiers go? and sum of the plumbing. im literly gesing whear things go, and thears no circet bord in box thears just plugs?

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Quote Originally Posted by K447 View Post
    ...
    See my signature links for some info and common issues regarding the blue Fuji engines...
    There is a LOT of info in there, will take some time to read through it

    Quote Originally Posted by stuart335 View Post
    thanks guys, i dont know whear the box was suposeto go so i did a temp fix to the hull top left rear top of muffler fr time being. now ive red a bit of info i now no whear it goes "lol" is thear any way i can get a fue pages from a manuale posted of emaild to me so i no egsakly whear theas wiers go? and sum of the plumbing. im literly gesing whear things go, and thears no circet bord in box thears just plugs?
    1992 was the very first year for Polaris watercraft. You can confirm your model year, check the last two digits on the HIN number plate on the rear deck.

    Polaris made a number of changes and improvements during the first few model years, so be aware that what you have may or may not be in original factory configuration.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hard Warm Starts on 1997 SLT 780 (blue Fuji engine)
    By polaris780slt in forum Polaris Open Discussion
    Replies: 17
    Last Post: 10-22-2013, 02:22 PM
  2. Electronics swap, blue Fuji and red domestic engines?
    By flounderingaround in forum Polaris Projects
    Replies: 3
    Last Post: 08-18-2013, 06:20 PM
  3. Replies: 7
    Last Post: 09-01-2011, 03:35 PM
  4. what gaskets need sealer on 94 sl750 polaris fuji engine
    By ultradoc in forum Polaris Projects
    Replies: 3
    Last Post: 10-16-2010, 08:26 PM
  5. Simptoms of a bad indexed crank blue fuji engine
    By mogyver69 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-08-2010, 08:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •