Results 1 to 10 of 10
  1. #1
    Qlake's Avatar
    Join Date
    Jan 2010
    Location
    Lake Quivira KS.& Punta Gorda FL.
    Posts
    66
    +1
    8

    Question 2012 FXSHO Cruiser OEM cover does not fit correctly.

    Anyone else have a factory cover that was made wrong? This is my second cover from my dealer and both fit very loose. The covers do not have enough material to allow the elastic to go under the lip so they will stay on. Yamaha customer service is no help and my dealer has no clue.
    I also have a VX and a VXR and both of their covers fit great.

    Thanks


  2. #2
    @JC's Avatar
    Join Date
    Sep 2012
    Location
    The Peoples Republic of Minnesota
    Posts
    1,861
    +1
    993
    Just buy a Jettribe cover, better quality/durability anyway from what I've been told. The dealer to threw in my oem cover or that's what I'd have bought.

  3. #3
    r33pwrd's Avatar
    Join Date
    Mar 2006
    Location
    Sammamish Washington
    Posts
    4,216
    +1
    360
    Are you putting it on from the front to the rear? (After putting center on first) Never heard of anyone having issues.

  4. #4
    Qlake's Avatar
    Join Date
    Jan 2010
    Location
    Lake Quivira KS.& Punta Gorda FL.
    Posts
    66
    +1
    8
    Quote Originally Posted by r33pwrd View Post
    Are you putting it on from the front to the rear? (After putting center on first) Never heard of anyone having issues.
    Yes, after owning 37 ski's over the past 39 years, (yes I'm old) I know how to install a cover. Thanks

  5. +1 by:


  6. #5

    Join Date
    Jan 2012
    Location
    SoCal
    Posts
    111
    +1
    3
    I thought the same thing when I got my FX SHO cover and put it on my Cruiser, I was having a heck of a time getting the side clips to clip to the underside of the rail. The cover on my FX HO Cruiser, also a factory cover, has no problem.

    So, how'd I get it to fit properly? It was a matter of adjusting the handlebar tilt down. Once I got the tilt right everything went on fine.

  7. #6
    Qlake's Avatar
    Join Date
    Jan 2010
    Location
    Lake Quivira KS.& Punta Gorda FL.
    Posts
    66
    +1
    8
    Quote Originally Posted by Yahooligan View Post
    I thought the same thing when I got my FX SHO cover and put it on my Cruiser, I was having a heck of a time getting the side clips to clip to the underside of the rail. The cover on my FX HO Cruiser, also a factory cover, has no problem.

    So, how'd I get it to fit properly? It was a matter of adjusting the handlebar tilt down. Once I got the tilt right everything went on fine.
    Thanks for the reply. I have tried adjusting the handelbars as well but the quality of the cover is about as good as the stitching in the seat....Very Poor. Come on Yamaha, is China making your covers now?

  8. #7

    Join Date
    Jan 2012
    Location
    SoCal
    Posts
    111
    +1
    3
    Out of curiosity, what part number did you get for the cover? Any chance you got a cover for the previous generation (2008-2011) instead of a 2012+?

  9. #8
    Qlake's Avatar
    Join Date
    Jan 2010
    Location
    Lake Quivira KS.& Punta Gorda FL.
    Posts
    66
    +1
    8
    Quote Originally Posted by Yahooligan View Post
    Out of curiosity, what part number did you get for the cover? Any chance you got a cover for the previous generation (2008-2011) instead of a 2012+?

    The box shows

    MWV-CRVCR-CH-12
    FX CRUISER HO SHO 2012 CHARCOA
    12-13 FX HO/SH

  10. #9
    Girls just wanna have fun! awarrick's Avatar
    Join Date
    May 2011
    Location
    Lake Lanier, GA
    Posts
    138
    +1
    1
    Quote Originally Posted by Qlake View Post
    The box shows

    MWV-CRVCR-CH-12
    FX CRUISER HO SHO 2012 CHARCOA
    12-13 FX HO/SH
    I am having the same issue. I got it on but the nose and back are really tight but the rest is fairly loose. Almost like they made them too short. My box had the same part#. I believe we do have the handlebars down too. Weird.

  11. #10
    Qlake's Avatar
    Join Date
    Jan 2010
    Location
    Lake Quivira KS.& Punta Gorda FL.
    Posts
    66
    +1
    8
    I'm glad it's not just me. Yamaha claims they have never had a complaint yet so please call customer service and let them know.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Driveshaft does not fit coupler? Check spline ends for impact/mushroom damage
    By patcmontgomery in forum Polaris Tech Tips and Info
    Replies: 8
    Last Post: 06-30-2016, 01:27 PM
  2. Got my custom seats covers on! 2012 FXSHO
    By awarrick in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 06-03-2014, 11:51 PM
  3. FS - Parts VX110 Cruiser OEM cover
    By ncdoo in forum Yamaha Classifieds
    Replies: 0
    Last Post: 05-11-2014, 04:54 PM
  4. Rear cowl air intake does not fit now ?
    By canuck in forum 4-Tec Performance
    Replies: 5
    Last Post: 10-11-2013, 11:59 PM
  5. yamaha 2012 fxsho, fxsho cruiser
    By nicjak in forum Yamaha PWC Performance (4-stroke)
    Replies: 13
    Last Post: 02-12-2012, 06:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •