Results 1 to 4 of 4
  1. #1

    Join Date
    Aug 2012
    Location
    Saint Petersburg, Florida, United States
    Posts
    13

    01 gp800r having 2 problems please help!!!

    So i finally made it out today for the first time this year.the first issue was with the speedo cluster. It wont work but its blinks and says start. The ski fired right up i have a new battery from walmart so it started with no issue out of water. So as i got out of my canal and gave it some gas it bogged out.. i can get up to 20 30 most likely as i said the gauge cluster didnt work so i dont know speed or rpm. I am going to change the spark plugs and run some carb cleaner tomorrow afternoon. Please help if you can any info will be greatly appreciated thanks again john.


  2. #2
    THE PLATE MAN JIM'S PERFORMANCE's Avatar
    Join Date
    Nov 2005
    Posts
    6,194
    +1
    536
    either carb. issue or power valve servo motor not working on the bog issue. On the cluster might be a bad connection or a bad cluster.

  3. #3
    SMLaker's Avatar
    Join Date
    Sep 2008
    Location
    Virginia
    Posts
    127
    +1
    3
    check your fuel filter, get some fresh gas, clean your carbs. Is it a premix or oil injected. Are you using ethanol gas? Gas cap on tight with no leaks, All can boggg U.

  4. #4

    Join Date
    Aug 2012
    Location
    Saint Petersburg, Florida, United States
    Posts
    13
    Its pre mix 50 1 and i use ethanol free.( it is from last season). Should i drain gas? ? It starts fine runs good in water at low speed just not wot thanks again.also gas tank has pressure when i unscrew gas cap

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. kawasaki 12-F problems...... please HELP
    By 0ne8one in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 10-25-2007, 12:50 AM
  2. 2007 RXP Problem! Please Help
    By Ericc in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-11-2007, 10:33 AM
  3. 02 1200r Power Problem please help
    By team11haro in forum Yamaha Open Discussion
    Replies: 10
    Last Post: 03-23-2007, 02:05 PM
  4. Genesis FFI Oil Problem- Please help
    By jmason2088 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 11-08-2006, 01:36 PM
  5. '05 Rxp Problem Please Help
    By WannabeGoing80 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-16-2006, 03:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •