Results 1 to 4 of 4
  1. #1

    Engine rev but go nowhere

    So I went 40 miles up river yesterday and everything was good, dropped it in the water today, and it revs up but it's only pushing water at a idle... Any ideas???


  2. #2
    GZA's Avatar
    Join Date
    Sep 2010
    Location
    New Zealand
    Posts
    423
    +1
    87
    More than likely something stuck on the impeller, peice of drift wood etc.

  3. #3
    I just crawled up in there I can't see anything

  4. #4
    Oh shit now I see something, crap. I thought something was really messed up.... Thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 09-08-2016, 04:22 PM
  2. 98 GP800 - Engine revs but lack of drive - new impeller and wear ring already fitted
    By Kiwivetten in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 02-06-2016, 03:16 PM
  3. 4-tec supercharger engine revs but wont move!!! Please Help!
    By theking549 in forum 4-Tec Performance
    Replies: 10
    Last Post: 10-14-2010, 08:02 PM
  4. 4-tec supercharger engine revs but wont move
    By theking549 in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 10-12-2010, 05:42 PM
  5. Gp1200 Caviatating! Will rev up but go NOWHERE HELP!
    By ktyamaha36 in forum Yamaha How To & FAQs
    Replies: 4
    Last Post: 03-30-2010, 02:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •