Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    2007 RXP oil loss/power loss

    I recently purchased a 2007 rxp 215 supercharged. It has not had the supercharger washers changed yet.

    Here is my problem. I took the ski out about a month ago and during the ride noticed a "beep" and it showed low oil pressure. I noticed oil coming from the drain plugs so i knew i had an oil leak somewhere. We took the ski to a buddy of mine to find that the oil filter cap and o rings were warped, and that was where the oil was coming from. I went and bought new parts from seadoo, fixed it and all was fine. Last week i take the ski out again and notice that when taking off, it seems as if its trying to spool up and take off but takes a few seconds to do so. My other two skis take off right away. I also noticed that there was an oil loss still and a good amount of oil in the bottom of the hull. I also noticed some stainless clamps in the bottom of the hull, but i cannot see any hoses missing a clamp (compared to my other rxp). We followed the proper oil change procedure (wot start to drain oil to oil pan, etc.) I also checked to see if the supercharger spins freely or easily, which it does not.

    So i guess here is my question, where do i start now. Is there a specific place i should go to on the engine to check for a leak?

    I also noticed the clear/yellow tubes toward the back of the hull that go to the drain plugs. They seem to be clogged with oil also. What are these tubes for?

    Any and all help is greatly appreciated.


  2. #2
    RXPJAY's Avatar
    Join Date
    Nov 2012
    Location
    Sudbury, Ontario
    Posts
    847
    +1
    93
    Clear yellow tubes are act as a bilge pump to remove water in the hull while riding. Check the oil filter cap. There is a seal there to that can be missing or not in place. If not, Clean out the hull 100%, start it up and narrow the area down. as for power, slip could be off on the charger.

  3. #3
    Thanks for the quick response. We just replaced the seals and the oil filter cap. It is possible that it could be coming from there, so i will check again. Is there any type of cleaner or degreaser i could use to clean out the hull? Also, could i use compressed air to blow out those tubes? I would only blow out the tube going to the drain plug.

  4. #4
    RXPJAY's Avatar
    Join Date
    Nov 2012
    Location
    Sudbury, Ontario
    Posts
    847
    +1
    93
    There are 90's that these tubes connect to. There usually only zip tied. Remove and blow them out. Also check your oil filler tube where it attaches to the block. Could be cracked. As for cleaning, any degreaser is fine. You can rinse with water and drain out the back with the plugs removed. Depending how much oil is in there, might want to drain it into a pail. How is your prop and wear ring? Exessive wear might cause you some power lose. What was your WOT RPM?

  5. #5
    I will have to check the wot rpm next time i go out. Im almost certain it is the same as my other rxp, but i will definitely check on that. As for the rear plugs, is there a seal between the plug and hull? Im assuming all you have to do is remove the two screws holding it on and it will come off? Or is there a sealant that is applied to the inside to seal it? Would you reccommend taking the oil filler tube off to inspect? Thanks for all your help.

  6. #6
    Also, Prop and wear ring seem to look just fine

  7. #7
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Do not ride the ski again till you change the supercharger washers.
    When they break its a whole world of hurt to the engine and VERY VERY COSTLY..
    It's a ticking time bomb with the ceramic washers in it..
    I've seen too many people in your situation that hated life after they broke the washers..
    Get the whole s/c rebuilt washers and bearings . That should be your top priority.

  8. #8
    Ok, Just called to setup to get my sc rebuilt. Around $600 for everything. I think its a fair deal so i wont bother doing it myself. Any other things that should be taken care of while its in the shop? Thanks

  9. #9
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Just make sure there doing a complete rebuild.
    Washers and bearings.

  10. #10
    Actually having both rxps done tomorrow. They are using the full rebuilt kit on both skis. Bearings, washers, new seals, etc. Thanks for all the help, now i just have to find out where this oil is coming from

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 RXP 215 loss of power
    By Rob1124 in forum Sea Doo Open Discussion
    Replies: 15
    Last Post: 07-26-2016, 02:29 PM
  2. Random RPM loss 2007 rxp HELP
    By skingelo in forum 4-Tec Performance
    Replies: 14
    Last Post: 07-18-2012, 07:26 PM
  3. 2007 RXP and BRP semi-synthetic oil?
    By 97GSX in forum 4-Tec Performance
    Replies: 14
    Last Post: 11-18-2011, 02:04 PM
  4. RXP-X Loss of acceleration and top speed
    By laarben in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-31-2008, 03:15 PM
  5. 04 RXP RPM loss/ Ride Style
    By ferny1usmc in forum 4-Tec Performance
    Replies: 4
    Last Post: 04-06-2006, 10:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •