Results 1 to 4 of 4

Thread: 1995 slt 750

  1. #1

    1995 slt 750

    Hi everyone, im a newbie to pwc's and im looking for a few tips, so here goes my story....
    I was recently given my aunt's 1995 slt 750 that hasnt ran for about 5 years, and have been working on it. The reason is stopped being ran was the fact that her retard ex husband put a lawn and garden battery in and it shorted out the magneto wiring. So i've gone through, completely rebuilt the engine and replaced the gaskets, fuel lines, and the magneto. Almost everything is going as its supposed to..... Except for one thing.... im not getting any spark.... Ive gone through and checked all my wiring, and i even cut the spark lines 1/4 in. and put the boot back on like i was recommended to. Now my question is, can anyone tell me how i can get spark?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Welcome

    See my signature links for the blue Fuji engine. In particular you want to ohm check the stator and related wiring.

    Installing the wrong battery would not short the electrical system. Installing the battery with reversed polarity would cause trouble.

    Be sure to check all the black ground wires, both inside and outside the electrical box. If there was a short the wire(s) could be toasted inside the insulation.

  3. #3
    it was not the fact that it was the wrong sized battery, the cdi didnt sit on top of the battery correctly and it fell, causing the wires to short out. and how do i check the ohms? also, does the mfd only come on when the engine is running? i am yet to see it come on.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by natedish97 View Post
    it was not the fact that it was the wrong sized battery, the cdi didnt sit on top of the battery correctly and it fell, causing the wires to short out. and how do i check the ohms? also, does the mfd only come on when the engine is running? i am yet to see it come on.
    There is supposed to be a plastic cover on the battery, and rubber straps to hold the electrical box (which contains the CDI and other stuff) in place on top of the battery.

    Omitting the plastic battery cover allows the metal shell of the electrical box to short to the battery positive post, and you end up with burned wires and troubles.

    The MFD has a fuse inside the electrical box. Replace it only with another 250ma (1/4 Amp) fuse. Disconnect battery negative post before opening up the electrical box.

    A working MFD connected to an undamaged electrical system will always show the clock.

    Spend some time reading the material at my signature links.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1995 Slt 750 Triple Pump Wow!!!!!
    By OLDJETSKIMAN in forum Polaris Open Discussion
    Replies: 25
    Last Post: 10-01-2008, 10:45 PM
  2. Please Help 1995 slt 750 cdi
    By sinclair in forum Polaris Open Discussion
    Replies: 0
    Last Post: 06-25-2008, 03:21 PM
  3. polaris 1995 slt 750 regulator/rectifier
    By sinclair in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 06-24-2008, 03:47 PM
  4. FS 1995 SLT 750 Polaris
    By jarcynvicnchris93 in forum Polaris Classifieds
    Replies: 1
    Last Post: 06-05-2008, 08:02 PM
  5. Just purchased a 1995 SLT 750.. Questions
    By daveo13 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 09-08-2006, 03:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •