Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 32
  1. #1
    usamps's Avatar
    Join Date
    Jul 2012
    Location
    fayetteville, nc
    Posts
    84
    +1
    1

    05 rxp died on water today! help would be appreciated.

    i was crusing along in the Cape fear river and my ski started skipping. it ran another 100 yards or so and just cut off. there were no codes on display..i tried to restart it and it made a terriable noise from the motor compartment.
    I raised the seat and had a little smoke came out smelt like oil. I got towed back to the boat dock by a yamaha ..i reallly love the rooster tail coming down on your head for a mile and half, but thank you chris for being there. i loaded it on the trailer and secured it , i proceded to try to start it and it turned and then made a horrible sound from inside the motor like metal was hitting. i stopped dead in my tracks and brought it home. i am getting ready to tear it down . i heard about weak valves and crankshaft issues. if anyone can help please let me know ., my cell is 910 644 7705, i am chris by the way. ty fellow jet ski riders.i am down but not out!


  2. #2
    To much is never enough Badvgood's Avatar
    Join Date
    Jun 2012
    Posts
    699
    +1
    31
    So when you try to start now it turns over but thats it yeah?

    Check for oil in the hull first and any visible damage to the block. Maybe post a video to youtube of you cranking it so we can see / hear what you can when cranking.

    May have dropped a valve as they were weak on the 05's / timing chain snapped / supercharger failed - The choices are endless at this stage as to why its packed up

    Oh and get under the ski and check the intake grate and impeller for debris that may have gone in and caused it to jam.

  3. #3
    usamps's Avatar
    Join Date
    Jul 2012
    Location
    fayetteville, nc
    Posts
    84
    +1
    1
    i removed the pump its fine. i have taken the intake off and am in the process of removing the head bolts, but i dont to remove the head yet , not yet anyway, if its good i would have to redo the timing. i have the service manual for the ski. i think i will pull the superchrger first and inspect it..what do i look for on the supercharger..if anyone would like to call and ask questions please do..i am chris..910 644 7705..its takes several hours on here to get questions answered. thanks everyone who is trying to assist me with this problem

  4. #4
    usamps's Avatar
    Join Date
    Jul 2012
    Location
    fayetteville, nc
    Posts
    84
    +1
    1
    Attachment 299672
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSCF0093.jpg 
Views:	98 
Size:	75.7 KB 
ID:	299669   Click image for larger version. 

Name:	DSCF0095.jpg 
Views:	93 
Size:	64.0 KB 
ID:	299670   Click image for larger version. 

Name:	DSCF0093 [640x480].JPG 
Views:	90 
Size:	87.0 KB 
ID:	299671  

  5. #5
    usamps's Avatar
    Join Date
    Jul 2012
    Location
    fayetteville, nc
    Posts
    84
    +1
    1
    would the supercharger wheel cause the motor to stop and sound like the motor is knocking...you can reveiw above pics

  6. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    If the bearings went out in the charger then yes.
    The charger shaft hooks to the flywheel and if it became unbalanced due to the bearing then your going to spend some $$$ and time fixing it.

  7. #7
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    Did you attempt to bump it over after you removed your charger?

  8. #8

    Join Date
    May 2010
    Location
    Highland, NY
    Posts
    37
    +1
    2
    How long did you ride it like that? I had a S/C go bad last year, it sounded like a seagull being tortured. Hopefully you get back on the water quickly.

  9. #9
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    Quote Originally Posted by jasen 2007 View Post
    How long did you ride it like that? I had a S/C go bad last year, it sounded like a seagull being tortured. Hopefully you get back on the water quickly.
    its not likely to be soon....

  10. #10
    Treemn's Avatar
    Join Date
    Jun 2007
    Location
    Coral Springs FL
    Posts
    3,322
    +1
    636
    What does the other side of S/C look like cause from those pictues it looks bad. Had the ceramic washers been changed.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 RXP Taking on water... Please Help!
    By Redspider in forum 4-Tec Performance
    Replies: 40
    Last Post: 08-22-2015, 05:07 PM
  2. Gp1200 dying on water, need help please
    By soulraver in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 08-08-2013, 10:54 PM
  3. Gp1200 dying on water, need help
    By soulraver in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 08-06-2013, 01:40 PM
  4. Unsure how these Mikuni Fuel pumps are plumbed...... Any Help would be appreciated...
    By SJ-(KY) in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-19-2010, 03:54 PM
  5. RXP taking on water, need help...
    By JetmechF16 in forum Sea Doo Open Discussion
    Replies: 32
    Last Post: 10-21-2009, 03:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •