Results 1 to 4 of 4
  1. #1

    Join Date
    Mar 2013
    Posts
    230

    Help, Cleaning the carbs on a 1996 Polaris sltx 1050

    My carb has some lag in it at low speeds. So i removed it to clean it out. It only has low speed idle screws. The high speed is open and has no screw in it. Is this normal?????


  2. #2
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    You should only have a low screw, no high.

  3. #3

    Join Date
    Mar 2013
    Posts
    230
    ok, thanks, just making sure

  4. #4
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    My first ski, purchased in 1999 was a 97' SLT750. I loved that ski.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help, 1996 Polaris sltx 1050, leaking fuel and oil out exhaust!!!!
    By jasonmd13 in forum Polaris Open Discussion
    Replies: 41
    Last Post: 05-09-2013, 07:34 PM
  2. 1996 polaris sltx 1050 runs bad after 10 minutes if hard riding
    By gvnitup in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-25-2010, 09:52 AM
  3. 1996 Polaris sltx 1050 problem
    By John0227 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-09-2010, 02:39 PM
  4. 1996 Polaris sltx 1050
    By diggerbug777 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-02-2008, 10:07 PM
  5. How to take the cylinder off a 1997 polaris sltx 1050
    By grifter in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 09-13-2007, 11:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •