Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Join Date
    May 2012
    Location
    mobile al.
    Posts
    24

    2002 genesis i 1200 need help

    I have a 2002 genesis i 1200, upgraded 12 mag flywheel, new stator, ran great for a few weeks. today i was riding and it just shut down. Checked fire and no1 cyl is not firing. 2 and 3 cyl and firing great. any ideas to what i can check? i have swaped coils and wire. coil and wire are fine. Thanks Steve


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Ficht engine firing on only two out of three cylinders = bad EMM.

    Everything else is common to all cylinders, so a bad sensor would not affect only one cylinder.

    You already swapped ignition coils, so that leaves the EMM.

    I do not believe cylinders 2 and 3 are 'firing great' yet the engine will not run at all. So that opens the possibility that the flywheel has sheared the woodruff key and the ignition timing is way off. But that would not cause only one cylinder to lose spark. So we are back to the EMM needing repair.

    You are using the correct spark plugs, yes?

  3. #3

    Join Date
    May 2012
    Location
    mobile al.
    Posts
    24
    Thanks for the reply man. I still have the factory plugs in. I think you are right about the emm, but what do you think goes bad in the emm. A resistor? I know the repair is around 600 bucks
    but is it a one time repair?

  4. #4
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Generally it seems once DFI fixes them they last. They do the repairs and a few upgrades as far as I know.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Quote Originally Posted by pierceboy1972 View Post
    Thanks for the reply man. I still have the factory plugs in. I think you are right about the emm, but what do you think goes bad in the emm. A resistor? I know the repair is around 600 bucks
    but is it a one time repair?
    Tip: Replace the spark plugs on a Ficht engine per the recommended frequency, even if the plugs still 'look good'. These Ficht engines REALLY like to have good, fresh NGK PZFR6H spark plugs.

    My understanding is that there are several components in the Ficht EMM that are known to fail;
    C89 is a large electrolytic capacitor on the back side of one board.
    Several of the semiconductors in the EMM 45 volt power rectifier section and others in the rapid fire ignition pulse circuits.

    Depending on which internal component(s) fails the EMM symptoms can vary.

  6. #6

    Join Date
    May 2012
    Location
    mobile al.
    Posts
    24
    Thanks guys. Im an automotive tech so im determined to fix everything myself, but much respect to you guys, cause i have alot to learn about these skies. So a bad emm will cause no 1 cyl
    only not to fire? I put a spark tester on 2 and 3 and they light up and pulse. Any other things i should check. Start stop module? Just making sure before i send it off.

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Quote Originally Posted by pierceboy1972 View Post
    Thanks guys. Im an automotive tech so im determined to fix everything myself, but much respect to you guys, cause i have alot to learn about these skies.

    So a bad emm will cause no 1 cyl only not to fire?
    I put a spark tester on 2 and 3 and they light up and pulse.

    Any other things i should check. Start stop module?

    Just making sure before i send it off.
    Your particular symptom of a single cylinder not getting spark is less common, but it can happen.

    There are separate electronic 'channels' inside the EMM. Each spark plug has its own driver, and each fuel injector also has its own section.

    Note: The Ficht Direct Injection injectors are complete different from typical automotive fuel injectors. The Ficht injectors are actually individual high pressure fuel pumps, one for each cylinder!

    Also, at low RPM the spark plug gets fired multiple times in rapid succession, not just once per power stroke. Even today, this is a fairly modern engine management technology.

  8. #8

    Join Date
    May 2012
    Location
    mobile al.
    Posts
    24
    Ok i understand. So anything esle you do u recommend me check before i send it off, and do i send the injectors with it? I would like to have a scanner i could plug in and check codes. Where would i buy one you think?

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Quote Originally Posted by pierceboy1972 View Post
    Ok i understand. So anything esle you do u recommend me check before i send it off, and do i send the injectors with it?

    I would like to have a scanner i could plug in and check codes. Where would i buy one you think?
    You can make a simple LED tool to read the EMM service codes.

    Details via my signature links, in the Ficht engine section

    No need to send the injectors to DFI, typically. Do send them the serial numbers and which cylinders they are mounted on, and DFI can verify you have the correct injectors for your EMM.

  10. #10

    Join Date
    May 2012
    Location
    mobile al.
    Posts
    24
    Man i charged the battery and now i have weak spark on no 1 cyl and no 3 cyl and very good spark on no 2 cylinder. before i charged the battery i on had spark on 2 and 3 cyl and not no 1 cyl. Its like it sparks sometimes and then dont. Now its constant weak fire on 1 and 3 and good on 2 . Any ideas. Still emm issue?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Please help 2002 genesis i 1200
    By pierceboy1972 in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 05-01-2013, 08:01 AM
  2. 2002 polaris txi Virage 1200 need help
    By sheldonbaker in forum Polaris Open Discussion
    Replies: 39
    Last Post: 10-04-2012, 10:16 AM
  3. 99XL 1200 need help
    By Cliff in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 10-23-2009, 02:57 PM
  4. 2002 GTX Ignition Problem, Need Help!
    By Ultra250XRider in forum 2-Stroke Performance
    Replies: 5
    Last Post: 06-05-2009, 06:58 AM
  5. 1999 Polaris Genesis Carb model need help with this one also
    By scottyboat in forum Polaris Open Discussion
    Replies: 1
    Last Post: 06-17-2007, 10:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •