Results 1 to 7 of 7
  1. #1

    GP1200 Impeller Duct Free Play?

    I am rebuilding a new to me GP1200. While inspecting the pump I noticed some free play in the impeller duct. The tie bolts are tight and the main shaft spins freely. I assume this is not right?
    Thanks

    Brian



  2. #2
    I wanna go FAAAAASTer!! CDW78's Avatar
    Join Date
    Mar 2010
    Location
    Ky
    Posts
    543
    +1
    6
    Seems like the whole pump is lose. IF the bolts are tight, maybe they arent really tight like they should be. Just my 2 cents

  3. #3
    Yeah I think you are right. The bolts seem tight and the pump nozzle doesn’t seem to be loose. The impeller duct shouldn’t move if its sandwich properly between the nozzle and wear ring. I don’t know how the duct can be loose if the wear ring and nozzle are tight??

    I guess I will tear into it and see what’s going on.

    Thanks

    Brian

  4. #4
    I wanna go FAAAAASTer!! CDW78's Avatar
    Join Date
    Mar 2010
    Location
    Ky
    Posts
    543
    +1
    6
    Id take it all apart and check it out, IF its easy to do.

  5. #5
    crashhard's Avatar
    Join Date
    Jul 2007
    Location
    Philly PA, Wildwood NJ, Indialantic FL
    Posts
    2,382
    +1
    24
    I would check the upper bolts for the wear ring

  6. #6
    Update

    I took the pump off today and found the whole pump stack was loose. The long tie bolts felt tight due to some corrosion on the threads but they were not clamping everything together.

    When the pump was in the boat the nozzle and wear ring felt tight because they are bolted to the boat and the duct was the only part that felt loose.

  7. #7
    OzarkYamMonster's Avatar
    Join Date
    Oct 2012
    Location
    Lake Of The Ozarks
    Posts
    2,152
    +1
    295
    As found out it was not really that difficult to remove the whole back puump section off the ski. As you re-assemble it use a good sealent and check all bolt threads. Good Luck

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GP1200 Impeller
    By zrtman in forum Yamaha Old School Skis
    Replies: 25
    Last Post: 08-12-2011, 07:48 AM
  2. WTB 1998 XL1200 Impeller duct
    By Glenn Briglio in forum Yamaha Classifieds
    Replies: 11
    Last Post: 10-26-2009, 05:45 PM
  3. WTB 98XL stock ride plate and impeller duct
    By Glenn Briglio in forum Yamaha Classifieds
    Replies: 0
    Last Post: 10-23-2009, 09:43 AM
  4. gp1200 impeller any advice
    By spyder3000gtvr4 in forum Yamaha PWC Performance (2-stroke)
    Replies: 11
    Last Post: 09-18-2006, 10:22 PM
  5. impeller duct damage
    By Yambo in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 02-05-2006, 11:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •