Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    Ryallen's Avatar
    Join Date
    Mar 2013
    Location
    Haughton LA
    Posts
    196
    +1
    13

    2000 Yamaha 1200 XL Limited problems

    I recently bought a 2000 1200 XL Limited with 140hrs. I tookit out this weekend and noticed some things that might be issues? aybe someone can offer some insight.
    Starting: when the ski is first started for the firstseveral minutes if you try to go WOT the ski will bog down and die. It seemslike it’s not getting fuel, almost like the fuel is slow running through thelines. Once it gets fuel its fine.
    Riding with two people: the ski leans to one side eitherright or left and is hard to get to bring back to level without turning sharplyto the other side then back center.
    Cruising: the top speed is only 50 [email protected] 7000 RPM…isthat normal?
    The mechanic told me the compression checked good and thecarbs were also just rebuilt.
    Thanks for any help.


  2. #2
    I believe replacing the ride plate with a RIVA or R&D may fix the lean issue.

  3. #3
    pokplalya22's Avatar
    Join Date
    Jun 2011
    Location
    NY
    Posts
    485
    +1
    4
    Check your sponsons, if you have these
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	140 
Size:	39.1 KB 
ID:	299862  

  4. #4
    pokplalya22's Avatar
    Join Date
    Jun 2011
    Location
    NY
    Posts
    485
    +1
    4
    Replace them with these. This, along with the rideplate/grate upgrade should solve your leaning issue. A new Rideplate should get you a few more mph's too
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	136 
Size:	25.6 KB 
ID:	299863  

  5. #5
    Ryallen's Avatar
    Join Date
    Mar 2013
    Location
    Haughton LA
    Posts
    196
    +1
    13
    I have the first sponsons, will be changing those out in short order...Thanks.

    Do you know what the top speed should be. I thought I should be getting 60mph stock.

    Also it's puzzling me why the first few minutes on the ski I can't go WOT without killing the engine...will using choke solve that?

  6. #6
    pokplalya22's Avatar
    Join Date
    Jun 2011
    Location
    NY
    Posts
    485
    +1
    4
    There is a cheap mod to eliminate to choke all together. It replaces it with a primer, and helps with cold starts. Honestly, I bought the ski with the primer, so not sure if theres an issue with the choke.

  7. #7
    pokplalya22's Avatar
    Join Date
    Jun 2011
    Location
    NY
    Posts
    485
    +1
    4
    And stock speed is around 50-55. A few mods should get you close to 60.

  8. #8
    It sounds like your accelerator pump is clogged. It injects fuel when you punch it. Also no need for primer on a ski with an accelerator pump. A couple quick pumps of the throttle will inject fuel straight into the carb

  9. #9

    Join Date
    Aug 2006
    Location
    Indiana
    Posts
    1,274
    +1
    81
    Yes there is a need for a primer on a ski with an accell pump if it won't start easy. Many yamaha's are hard to start even when the accell pump works. My new XLT was hard to start cold from day one, rebuild carbs a few years ago, pump checked out perfect. Still hard to start. Install primer, no more problem. No need to wear your starter out if a primer will correct the problem. this fix has worked for several other boats I have worked on.
    For reference, GPR's and XLT's accell pump only injects on cyl 1 & 3.
    My GPR never needed a primer, it always started right up so I don't know why some start easy and some don't.

    Quote Originally Posted by Wire4Money View Post
    It sounds like your accelerator pump is clogged. It injects fuel when you punch it. Also no need for primer on a ski with an accelerator pump. A couple quick pumps of the throttle will inject fuel straight into the carb

  10. #10

    Join Date
    Aug 2006
    Location
    Indiana
    Posts
    1,274
    +1
    81
    You may want to check speedo paddle wheel down on the rideplate. a few weed hairs and such about the sides of paddlewheel slow the speedo down.
    Quote Originally Posted by Ryallen View Post
    I have the first sponsons, will be changing those out in short order...Thanks.

    Do you know what the top speed should be. I thought I should be getting 60mph stock.

    Also it's puzzling me why the first few minutes on the ski I can't go WOT without killing the engine...will using choke solve that?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. where to connect 2000 Yamaha 1200 xl ltd exhuast temp sensor
    By spray&Splash2011 in forum Yamaha How To & FAQs
    Replies: 8
    Last Post: 09-27-2014, 08:20 AM
  2. yamaha 1200 xl limited problems
    By bbowen25 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-06-2013, 08:27 PM
  3. How much should I spend.. 2000 yamaha 1200 xl
    By djrowe007 in forum Yamaha PWC Performance (2-stroke)
    Replies: 20
    Last Post: 07-18-2012, 05:24 AM
  4. 2000 Yamaha 1200 XL Dead #3 Cylinder
    By btroxell in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 07-26-2010, 10:26 AM
  5. 1999 Yamaha 1200 XL Limited oil block off
    By lagernuts in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 07-04-2010, 09:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •