Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    1998 GTX Limited-No mid range

    Looking for a little help. Rebuilt the carbs and took her to the lake. Starts and idles perfect. Bogs bad trying to accelerate, but once it got up the step feathering the choke, runs perfect at full throttle. As soon as you let off the throttle, it stalls as if it's electrical. So between 3000 and 6000 rpm, it will not run. I'm guessing it's a carb issue, but anyone with similar experience and fix would be appreciated.


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,523
    +1
    1,270
    describe how the carbs were rebuilt. Leave out no detail

  3. #3
    All needle jets removed and cleaned. Diaphrams and screens replaced. All passageways cleared w/compressed air. I think the accelerator pump was cleaned and checked. I'll admit it's not a top shelf rebuild. The bodies were not soaked overnight. The strange thing is when letting off the throttle even slightly from WOT it quits immediately. That's the confusing part. I understand if the pump is not functioning it would bog trying to get to WOT. Setup is stock. System fuel lines are all new w/new fuel filter. I just cleaned the Raves, though they looked pretty good. Thanks for your reply Pete.

  4. #4
    blacktop's Avatar
    Join Date
    Mar 2013
    Location
    South Florida
    Posts
    51
    Make sure u don't have aftermarket flame arrestor (air filter over carbs) that's what my problem was, and as soon as I changed the jets and springs it ran perfect throughout the whole rpm range

  5. #5
    I was just reading the manual and if the solenoid for the Raves is inop, could that cause this situation? It sounds like they are either open or closed based on inputs. Is it possible to open them if the revs get to WOT without a functioning solenoid?

  6. #6
    Stock airbox Blacktop.

  7. #7
    blacktop's Avatar
    Join Date
    Mar 2013
    Location
    South Florida
    Posts
    51
    Check your pop off pressure

  8. #8
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,523
    +1
    1,270
    Quote Originally Posted by blacktop View Post
    Check your pop off pressure
    there was no indication that the needles and seats were changed.

    if my feeble old memory serves me correctly, the throttle cable has some adjustment and a sensor that helps control the ignition timing. You'll want to be looking at that to make sure it's adjusted as the manual states ( don't have the 1998 manual here, but I've tangeled with this cable before, it's somewhat unique in the business)

    Did you change the check valves on the fuel pump?..how did you determine which way was up on the check valves?

    pull the plugs and describe the color of the insulators that are in the tip. If all white, fuel delivery problem, all black, too much fuel, brown or tan/just right.

    before you pulled the carbs apart..how did it run?

    raves are a red herring at the moment, the engines run with them inoperable, but with a reduced powerband and top speed ( well actually depends where they are stuck, open or closed) they only control exhaust port timing, so leave that out of the mix for the moment

  9. #9
    I was given the ski non running. Had original fuel lines, all changed. Carbs were a mess, full of green and gray goo. Checked the manual and no throttle adjustment for this year/ 947 motor.
    I just ran it again after cleaning the Raves and setting and tweeking the low speed needles. It will accelerate to WOT if you tweek the choke. I'm pretty sure the pop-off is incorrect. Will remove them and have them tested. Thanks for all the input, will repost when the smile is back on my face!

  10. #10
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    Check the plugs readings (color) that will tell you what direction they are at. Other things I would check are the crank seals-you wont be able to check the front one cause its behind the Magneto but remove the PTO cover on the rear of the motor , start it on the trailer and spray carb cleaner between the block and the pto and see if it changes the rpm. also check the reed valves next... Reason i say check the seals is because when you pull the choke it runs? so 1,either its sucking air from there and giving the motor a more balanced air/fuel ratio or vice-versa,...its not getting enough fuel....

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 Seadoo GTX Limited No water flow.
    By pseadoo in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 08-02-2016, 07:57 PM
  2. 1998 gtx limited bogging
    By dashig in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-29-2009, 03:50 AM
  3. 95 780 slx no mid range Idle and full throttle is all
    By fireman24mn in forum Polaris Open Discussion
    Replies: 5
    Last Post: 05-31-2009, 03:43 PM
  4. Replies: 3
    Last Post: 04-21-2009, 01:48 PM
  5. WTB: Hood for 1998 GTX Limited
    By JohnCiccarelli in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 11-30-2008, 08:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •