Results 1 to 5 of 5
  1. #1

    Join Date
    Sep 2010
    Location
    Dundee, MI
    Posts
    137

    1999 STX Questions

    Hello everyone,
    Been a member on here for a couple of years now, but have been over on the Polaris side. Last fall I picked up a 99 STX, minus the long block, so I am pretty much a newbie when it comes to Kawasaki's. I bought a long block off of Ebay from a 97 STX, rebuilt it, and am in the middle of putting it in the 99 STX. There are two impulse ports on the 97 engine, one on the left, one on the right. My set of carbs from the 99 only has one connector for the impulse line, so can I just plug the one that isn't needed, or am I missing something here? Also, I have a bracket left that I am positive is for the choke cable, but any way I try to bolt it to the engine the holes don't seem to align to the bracket. A pic of the bracket mounted would be great. But, if not, any help would be appreciated.

    Thanks....Terre

    Click image for larger version. 

Name:	IMG_1314.jpg 
Views:	27 
Size:	40.3 KB 
ID:	300016Click image for larger version. 

Name:	IMG_1311.jpg 
Views:	39 
Size:	104.4 KB 
ID:	300015


  2. #2
    TexasZ's Avatar
    Join Date
    May 2012
    Location
    Near San Antonio, Texas
    Posts
    460
    +1
    34
    Yes on the extra impulse line, just plug it.
    The bracket you are showing probably isn't needed. Did it come with the 97 engine? The 97 STX had the CDKII carbs, whereas the 99 has the CV carbs. The bracket that is on your engine now looked to have the hookup mount for both cables.

  3. #3

    Join Date
    Sep 2010
    Location
    Dundee, MI
    Posts
    137
    Quote Originally Posted by TexasZ View Post
    Yes on the extra impulse line, just plug it.
    The bracket you are showing probably isn't needed. Did it come with the 97 engine? The 97 STX had the CDKII carbs, whereas the 99 has the CV carbs. The bracket that is on your engine now looked to have the hookup mount for both cables.
    Thanks TexasZ for the reply. I made a mistake in my first post, I meant to say oil pump cable, and not the choke cable. Not sure how I got that mixed up, but I did. I think the bracket is for the oil pump cable, but I don't see how it bolt to the engine. The bracket came with the ski. Thanks again for the help.....Terre

  4. #4
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,011
    +1
    283
    The '97 had a fixed ratio oil pump, it doesn't use the cable.

    Here's a link to the '99, which apparently did have the cable: http://www.powersedge.com/pages/OemP...C18C1816E1710A

  5. #5

    Join Date
    Sep 2010
    Location
    Dundee, MI
    Posts
    137
    Quote Originally Posted by steve45 View Post
    The '97 had a fixed ratio oil pump, it doesn't use the cable.

    Here's a link to the '99, which apparently did have the cable: http://www.powersedge.com/pages/OemP...C18C1816E1710A
    Thanks, that's exactly what I needed, thanks for the responses.....Terre

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1999 STX: Air in main oil line leading to oil pump
    By Junkster in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 04-29-2015, 06:41 PM
  2. 1999 STX 900 big troubles
    By rondo57 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 7
    Last Post: 01-28-2015, 04:53 PM
  3. 951 GTX 1999 seadoo question
    By shooter98xpl in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-09-2010, 09:45 AM
  4. 1999 Spx questions
    By Chaserxp215 in forum 2-Stroke Performance
    Replies: 21
    Last Post: 02-26-2009, 03:41 PM
  5. 900 STX Questions
    By jclaudii in forum Kawasaki Open Discussion
    Replies: 23
    Last Post: 03-11-2008, 09:08 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •