Results 1 to 9 of 9
  1. #1
    xplayer2885's Avatar
    Join Date
    Sep 2006
    Location
    LI, NY
    Posts
    1,251
    +1
    43

    Just did the round MFD fix.....

    Holy crap it works perfectly!!! I was in shock. Cutting it apart really isnt that bad just go slow. As for putting it back together i used clear silicon. Is that going to be enought to hold it?


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    I have used black RTV with good success. If its a quality silicone I would think its strong enough.

  3. #3
    Fink's Avatar
    Join Date
    Mar 2013
    Location
    North East Arkansas
    Posts
    258
    +1
    5
    Congrats!!!

    I need to open mine up (oval) but at this point I'm just trying to make the ski safe to ride.

  4. #4
    xplayer2885's Avatar
    Join Date
    Sep 2006
    Location
    LI, NY
    Posts
    1,251
    +1
    43
    Well bad news. I went to remove the old graphic decal on the MFD to replace it with a new one.....I ripped off the ribbon. Such a poor design on the manufactures part.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,601
    +1
    1,276
    Quote Originally Posted by xplayer2885 View Post
    Well bad news. I went to remove the old graphic decal on the MFD to replace it with a new one.....I ripped off the ribbon. Such a poor design on the manufactures part.
    Did you apply a heat gun to soften the adhesive first?

  6. #6
    xplayer2885's Avatar
    Join Date
    Sep 2006
    Location
    LI, NY
    Posts
    1,251
    +1
    43
    Nope...It was already peeling off so i just slowky removed it in one piece..........An im supposed to be the doctor in the family lol

  7. #7
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    IM pretty sure thats not a decal......

  8. #8
    xplayer2885's Avatar
    Join Date
    Sep 2006
    Location
    LI, NY
    Posts
    1,251
    +1
    43
    Quote Originally Posted by BryanP View Post
    IM pretty sure thats not a decal......
    Actually yes part of it is....First is a clear plastic coating, then the graphick decal, then the adehesive senser, followed another double sided adesive all sandwich together.......Shit happens.

  9. #9
    notorious01's Avatar
    Join Date
    Jul 2012
    Location
    NJ
    Posts
    215
    +1
    2
    You open this for what? moisture?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 5
    Last Post: 05-26-2011, 11:51 PM
  2. WTB WTB broken Ultra 150 or comparable MFD/gauges. I just need the face!
    By jcc011185 in forum Kawasaki Classifieds
    Replies: 0
    Last Post: 10-20-2010, 10:39 PM
  3. Just did the red/purple mod and now the bilge runs all the time.
    By friscoboater in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-27-2010, 03:36 PM
  4. I just joined the AWA
    By Green Hulk in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 11-21-2008, 10:53 AM
  5. Where did the home page button go??
    By boataddict in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 09-19-2005, 01:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •