Results 1 to 4 of 4
  1. #1

    Join Date
    May 2013
    Location
    North Texas
    Posts
    2

    Stripped where drive shaft spline meets engine

    I have installed a new prop, wear ring, water pumps and gaskets. Spline on shaft looks great and is not worn. But, when engine is cranked, there is a non metal on metal grinding sound and the prop doesnt turn. Is there a tranny for these things or is there a rubber type sline gromet that the spline fits into? I am about to operate on this thing when I get back home and was wondering if you had any pointers. Thank you.


  2. #2
    showmepro1200's Avatar
    Join Date
    Sep 2006
    Location
    Jefferson City MO (Ride at Lake of the Ozarks)
    Posts
    524
    +1
    40
    Let everyone know what model/year you are speaking of, so folks can give you pointers specific to their experiences with your machine.

    That said, it kinda sounds like you need to be pulling the midshaft assembly to see what the splines on that end look like.

  3. #3
    Banned User
    Join Date
    May 2006
    Posts
    1,329
    +1
    152
    u sure the new prop is not grinding on the ware ring or even locked up. There are dow pins for line up. Its a tight fit

  4. #4
    showmepro1200's Avatar
    Join Date
    Sep 2006
    Location
    Jefferson City MO (Ride at Lake of the Ozarks)
    Posts
    524
    +1
    40
    Quote Originally Posted by Rocketman View Post
    u sure the new prop is not grinding on the ware ring or even locked up. There are dow pins for line up. Its a tight fit
    Thats a good point - should have asked what was the situation before you did all the recent work you described?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2010 RXT-X Drive-Shaft spline failures.
    By Toobold in forum 4-Tec Performance
    Replies: 22
    Last Post: 03-26-2017, 04:40 AM
  2. Drive Shaft/Splines Problem
    By rocstar09 in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-06-2013, 12:50 PM
  3. 2010 Drive shaft spline issue...
    By djblack in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-29-2012, 12:46 PM
  4. Think I stripped my drive shaft
    By ironman_gq in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-16-2012, 05:11 PM
  5. drive shaft spline tool??
    By WAGZ102 in forum Yamaha How To & FAQs
    Replies: 1
    Last Post: 04-20-2008, 05:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •