Results 1 to 6 of 6
  1. #1

    Join Date
    Jun 2012
    Location
    McCalla, Alabama, United States
    Posts
    46

    Wave Venture propulsion question.

    I just replaced the 63m motor in my wife's ski and was taking it for a test run this weekend. It ran great and then we rode through a section of the river that had a lot of trash / debris in it. After that, her ski would move a long at idle and just above but if she revved it up, it wouldn't take off and go like it should. We limped it back to the dock and when I got it home, I looked up in the intake grate and found half of a plastic cup up in the impeller. Would this cause it to rev and not go anywhere like it should? Everything else looks fine from what I can tell.

    Thanks,

    Teddy


  2. #2
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    598
    yes it would, any trash in the pump will foul it

  3. #3

    Join Date
    Jun 2012
    Location
    McCalla, Alabama, United States
    Posts
    46
    Click image for larger version. 

Name:	Impeller FOD.jpg 
Views:	26 
Size:	13.3 KB 
ID:	300371

    This was it.

  4. #4
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,771
    +1
    129
    I once had just a part of somebodys lunch sandwich bag get in mine, no faster than an idle.

  5. #5
    Yamaha artisan Cutlass's Avatar
    Join Date
    Oct 2010
    Location
    Madison, WI, USA
    Posts
    2,500
    +1
    55
    Quote Originally Posted by Gearbanger View Post
    I just replaced the 63m motor in my wife's ski and was taking it for a test run this weekend. It ran great and then we rode through a section of the river that had a lot of trash / debris in it. After that, her ski would move a long at idle and just above but if she revved it up, it wouldn't take off and go like it should. We limped it back to the dock and when I got it home, I looked up in the intake grate and found half of a plastic cup up in the impeller. Would this cause it to rev and not go anywhere like it should? Everything else looks fine from what I can tell.

    Thanks,

    Teddy
    Next time that happens, shut the engine off, hop in the water and reach up under there and see if you can clear out the trash in the pump. That trash can also restrict the cooling water flow to the engine and cause it to overheat so be careful not to run it too much with a clogged pump

  6. +1 by:


  7. #6

    Join Date
    Jun 2012
    Location
    McCalla, Alabama, United States
    Posts
    46
    The pump didn't seem to be clogged because it was shooting water out the pisser really well. The only reason I didn't check it in the water was because the water was 51 degrees and I didn't feel like taking a swim... Maybe I shouldn't have cut out the two inner rails on the intake grate. Duh!!! At least I know what to look for now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1997 Yamaha Wave Venture 1100 carb, zert, and maintenance questions
    By ianshives in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 04-27-2017, 06:45 PM
  2. 1100 wave venture carb question.... This one seems different ???
    By C-Phase in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 07-06-2014, 08:24 PM
  3. 1996 Wave Venture Jet pump question
    By pjv911 in forum Yamaha Old School Skis
    Replies: 6
    Last Post: 12-14-2011, 06:53 PM
  4. Couple of wave venture questions.
    By firefighterski2010 in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 03-06-2011, 03:52 PM
  5. Question on Wave Venture 701
    By orangeman in forum Yamaha Old School Skis
    Replies: 1
    Last Post: 07-03-2008, 03:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •