Results 1 to 8 of 8
  1. #1
    Ratrace's Avatar
    Join Date
    Feb 2013
    Location
    Jersey Shore
    Posts
    269
    +1
    12

    Polaris Virage TXI 2002 compression problem

    just put new SBT pistons in. clearance for each piston was bored to .005"..less then Polaris specks. I now have 70, 90, 96 psi. did a leak down test and it leaking through the pistons. the heads are good with no leaks. what could I have done wrong. this is not my first rebuilt. HELP!!


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    What do you mean leaking through the pistons? Are you doing the test with the plugs in?

  3. #3
    Ratrace's Avatar
    Join Date
    Feb 2013
    Location
    Jersey Shore
    Posts
    269
    +1
    12
    Quote Originally Posted by BryanP View Post
    What do you mean leaking through the pistons? Are you doing the test with the plugs in?
    no plugs...testing each cylinder with no plugs

  4. #4
    Ratrace's Avatar
    Join Date
    Feb 2013
    Location
    Jersey Shore
    Posts
    269
    +1
    12
    Quote Originally Posted by BryanP View Post
    What do you mean leaking through the pistons? Are you doing the test with the plugs in?
    by the way ..I used 1mm over pistons from SBT

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    Quote Originally Posted by Ratrace View Post
    just put new SBT pistons in. clearance for each piston was bored to .005".. less then Polaris specks. I now have 70, 90, 96 psi.

    did a leak down test and it leaking through the pistons. the heads are good with no leaks.

    what could I have done wrong. this is not my first rebuilt. HELP!!
    So your compression results when cranking are 70, 90, 96 psi, correct?

    This was done with all spark plugs out, throttle held wide open, strong battery?

    SBT pistons, 85mm size, cylinders bored .005 larger than the pistons, correct?

    Have you actually measured the piston sizes and measured the cylinder sizes to verify the clearances?

  6. #6
    Ratrace's Avatar
    Join Date
    Feb 2013
    Location
    Jersey Shore
    Posts
    269
    +1
    12
    done all that.. the piston is tapered so the clearance is measured from the widest point

  7. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    The rest of this 1165cc Virage TXi engine is original/OEM spec? Just the pistons were changed?

    Ficht Fuel Injectors in place and properly seated and sealed to the heads?

    Exactly which SBT pistons are these? Part number or box photo?

    I am wondering if the pistons are incorrect parts, somehow.

  8. #8
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    4,988
    +1
    140
    Quote Originally Posted by K447 View Post
    I am wondering if the pistons are incorrect parts, somehow.
    If I recall, this did happen not too long ago in another thread. Box was correctly marked, piston and/or rings were incorrect......

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help Please Polaris virage txi 2002
    By Elunicogaby in forum Polaris Open Discussion
    Replies: 12
    Last Post: 09-23-2013, 12:29 AM
  2. Polaris Virage TXi 2002 battery is not charging
    By Lee Luetge in forum Polaris Open Discussion
    Replies: 4
    Last Post: 07-08-2013, 02:31 PM
  3. Polaris Virage TXI 2002 fuel injectors question
    By Ratrace in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-07-2013, 08:48 AM
  4. Polaris Virage TXi 2002 - Backfire, EMM codes 12 & 17
    By JENNAANDRICK in forum Polaris Open Discussion
    Replies: 8
    Last Post: 06-09-2011, 02:50 PM
  5. 2001 polaris virage txi stalling/starting problem
    By 2000 gtx rfi in forum Polaris Open Discussion
    Replies: 1
    Last Post: 05-01-2011, 09:36 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •