Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
  1. #1
    pete71's Avatar
    Join Date
    Apr 2007
    Location
    AUSTRALIA(Melb)
    Posts
    685
    +1
    21

    Maybe time to divorce my seadoo ?

    I have loved this ski since I've had it , have taken so much pride in her
    taken her for long rides along the beach
    bought this 2010 rxtx about 9 months ago with 45 hrs on it( now has 96) , I reflashed the ecu with v tech 8350 rpm , 4"air,15/21 solas and 2012 x sponsons
    Did a drive shaft and upgraded to the 2011 setup after engine alignment and new carbon ring

    this week installed et s/c cooler,brand new x charger and thru hull exhaust,went to the boat ramp today to start it up and check for leaks and my bitch did this " ANOTHER CARBON RING " after only 20 hrs

    i feel like this ski just kicked me in the NUTS !!


  2. #2
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Something is not right there. Three blades are hard on the seal but you have a four. What exactly happened, i have seen it where the shaft gets worn in the c clip groove and people have problems with the C clip coming out... But if your carbon seal has broken then maybe if was a defective piece.

    R88

  3. #3
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Ahh, make sure your air intake is not sitting/pushing on the seal, that can cause issues, seeing you have fitted new SCer and that.

    R88

  4. #4
    GasResearch-VT.SE's Avatar
    Join Date
    Nov 2012
    Location
    Melbourne, Australia
    Posts
    1,172
    +1
    207
    Quote Originally Posted by pete71 View Post
    I have loved this ski since I've had it , have taken so much pride in her
    taken her for long rides along the beach
    bought this 2010 rxtx about 9 months ago with 45 hrs on it( now has 96) , I reflashed the ecu with v tech 8350 rpm , 4"air,15/21 solas and 2012 x sponsons
    Did a drive shaft and upgraded to the 2011 setup after engine alignment and new carbon ring

    this week installed et s/c cooler,brand new x charger and thru hull exhaust,went to the boat ramp today to start it up and check for leaks and my bitch did this " ANOTHER CARBON RING " after only 20 hrs

    i feel like this ski just kicked me in the NUTS !!

    Did the charger come out with a thud?
    Just thinking how it may have cracked it.

  5. #5
    Steve-m31164's Avatar
    Join Date
    Jan 2013
    Location
    Melbourne Australia
    Posts
    2,690
    +1
    403
    Yeah mate its junk ... part it out ... i need some parts for my conversion lol .......its going to be a long cold winter here , you have plenty of time to fix it ...

  6. #6
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Recheck that alignment I can't tell you what was thought to be good not...

  7. #7
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    Definitely troubleshoot it and fix it. Don't pass your problems off on someone else or karma will hit you on the next ski.

  8. #8
    SLASHER's Avatar
    Join Date
    Jun 2007
    Location
    Australia, Perth WA
    Posts
    3,263
    +1
    474
    Quote Originally Posted by pete71 View Post
    I have loved this ski since I've had it , have taken so much pride in her
    taken her for long rides along the beach
    bought this 2010 rxtx about 9 months ago with 45 hrs on it( now has 96) , I reflashed the ecu with v tech 8350 rpm , 4"air,15/21 solas and 2012 x sponsons
    Did a drive shaft and upgraded to the 2011 setup after engine alignment and new carbon ring

    this week installed et s/c cooler,brand new x charger and thru hull exhaust,went to the boat ramp today to start it up and check for leaks and my bitch did this " ANOTHER CARBON RING " after only 20 hrs

    i feel like this ski just kicked me in the NUTS !!

    U just having a lovers tiff .... Lol .....Keep the ski ...

  9. #9
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by R88ory RXP View Post
    Ahh, make sure your air intake is not sitting/pushing on the seal, that can cause issues, seeing you have fitted new SCer and that.

    R88
    +1 Double check your carbon ring/seal area. Make sure the flap on the PTO bearing is ok. I have been cutting them off lately.

  10. #10
    surferd15's Avatar
    Join Date
    Jun 2007
    Location
    Fort Lauderdale, FL
    Posts
    1,142
    +1
    83
    Mine was replaced by dealer not long ago about 50 hours, I now have about 89 hours and its leaking again. This is a new machine and first one was covered under warrenty and they found that the engine was mis-aligned. Now this one not sure yet, but it leaks!

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Time to Mod my GTR 215
    By chripark in forum 4-Tec Performance
    Replies: 38
    Last Post: 11-01-2017, 11:34 AM
  2. I think it's time to sell my kawi 300x for a Yamaha. need opinion!
    By mruss in forum Yamaha PWC Performance (4-stroke)
    Replies: 52
    Last Post: 07-31-2014, 03:52 PM
  3. I think its time to rebuild my fx140 engine mr1 =(
    By andy95'slx780 in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 01-14-2012, 08:23 AM
  4. What is the best way to sell my SeaDoos?
    By bankyf in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 07-09-2008, 03:32 PM
  5. Time to check my nuts and bolts
    By pirate33 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-18-2007, 11:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •