Results 1 to 8 of 8
  1. #1

    Join Date
    Apr 2013
    Location
    Ontario Canada
    Posts
    15

    Exclamation Need help quick, water in engine bay help.

    i just got my seadoo from the shop today and decided to take it out for a ride, soon as i left the dock i hear a weird screeching noise so i stop and pull the engine cover and see the engine slowly filling with water, the water got to just bellow the oil filter but over the supercharger, im taking it back to the shop but is there anyway that i can check or any signs that water has got into the engine or anywhere in the engine without dis-assembly? for future reference? thanks.


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Pull off the hose from the charger and drain the water out before you try to start it.
    Pull the spark plugs after and spin it over.
    If water comes out of the spark plug holes then keep spinning in over in 10 second intervals.
    Give the starter a chance to cool. Then repeat.
    After that check your oil and see if its milky colored.
    Was it fresh water or salt water?
    If water does come out the spark plug holes then put some oil in the cylinders and spin it over again without the spark plugs.
    The sooner you get her running and you can run her for 30+ min the better.
    I've seen milky oil evaporate out when a ski is run for 30+ min.
    If its milky then change it 2-3 times before running it.
    Tick tock the longer you wait the more permanent the damage is.
    Good luck!!!

  3. #3

    Join Date
    Apr 2013
    Location
    Ontario Canada
    Posts
    15
    If no water come out of the charger or spark plug holes, and oil is not milky should i assume all is good? or is there any other things i should look at? also it is fresh water. thanks again.

  4. #4
    Aussiepauly's Avatar
    Join Date
    Jan 2012
    Location
    Sydney Australa
    Posts
    898
    +1
    70
    Quote Originally Posted by RaceReady View Post
    If no water come out of the charger or spark plug holes, and oil is not milky should i assume all is good? or is there any other things i should look at? also it is fresh water. thanks again.
    That's right, no water in engine means all good! Now you have to find out where your leak came from, check your exhaust hoses first otherwise carbon seal, back it into water on trailer, start it, and then you will see where the water is coming in from! But your dealer should do this under warranty!

  5. #5

    Join Date
    Apr 2013
    Location
    Ontario Canada
    Posts
    15
    How quick will the oil turn milky? Also i pulled the plugs this morning only gas vapour came out, also the supercharger piping was dry, and the oil is still light brown. all should be good right? i also found the issue. its the small nut that holds the Forward and revers cable in place at the back on the jet housing that cracked and gave way causing water to flood in. i guess i got lucky that no water got in the engine as i just had it in for service to get new valves installed as i had the hollow #72 valves.
    Last edited by RaceReady; 05-09-2013 at 11:06 AM. Reason: New info.

  6. #6
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    Good find on the issue............your next mod should be to add a bilge pump!

  7. #7

    Join Date
    Apr 2013
    Location
    Ontario Canada
    Posts
    15
    I thought the rxp's had them built in from the factory, isnt that what the two small holes are for on the body under bumber on the side?

  8. #8
    Tucka's Avatar
    Join Date
    Jun 2012
    Location
    mount warrigal NSW Australia
    Posts
    106
    +1
    14
    That really sucks , a new ski and it takes in water. Hopefully you only forgot to screw in the two bungs at the back end of the ski and its not the carbon seal.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Water in engine bay
    By Tim777 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 12-09-2012, 04:33 PM
  2. Water in Engine bay RXP???
    By Five 0 in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-11-2010, 07:41 AM
  3. Pro 785 ADVISE? Water in engine bay over winter
    By princy83 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 04-19-2010, 06:25 AM
  4. Rxt - x salt water in engine bay
    By jetski in forum 4-Tec Performance
    Replies: 6
    Last Post: 11-05-2008, 04:14 AM
  5. 99 1100 ZXi Water in engine? Need help!!
    By tyler_stephen in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 04-29-2007, 01:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •