Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    Is my supercharger clutch gone?

    I bought a used 06 rxp with 11 hours on it. The rpms were normal the first day I rode it (8100-8200 rpm) and the sc whistled. So every thing seem to work fine except I wasn't sure if the rxp sometimes has some pump cavitation issues off the starts and especially during slow turns. The second day I took it out and as soon as I hit WOT for 20 seconds I noticed sever power loss, and can't hear the sc anymore. I put a whopping 1 1/2 hrs on this unit since I bought it. I Immediately rode it back to the dock in idle. Is this a sc issue for sure or could it be something else?
    Thanks in advance, Jimmy from Houston


  2. #2
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    it may be, or it may not be....

    you experienced cavitation before the problem, so it COULD be something in the propulsion system. damaged wear ring, damaged prop, debris caught in the pump...

    if all this checks out ok, then it COULD be the supercharger.

    either way... don't start it or ride it anymore... it's an 06... so it's probably still got warranty on it. ACT NOW... when is the warranty over, do u know?

    check the pump, prop, wear ring... if all that is ok, then bring it to a VERY VERY VERY reputable dealer that knows about supercharger failures and knows how to fix it properly.

    second thing... if you don't have an extended warranty... BUY ONE!!!

    LASTLY... welcome to the forum. you found the right place!!

  3. #3

    Thanks for the quick response...

    I will check the pump as you stated. Unfortunately I have never been on an rxp besides this one so I'm not sure if It was ok when I bought it. The cavitation was mostly when turning but I wasn't expecting any? Do the rxp's cavitate when you hit WOT (from a dead stop )while trying to spin around. My other seadoo's never really do that. I watched my friend ride his one day and his seem to have a lot more power from dead stop. (he was spinning in circles and it was whipping around). I do have an extended warranty. A reputable dealer in Houston is real hard to find. I haven't been to all the dealerships but the ones Ive been to are never able to fix my problems. Can anyone out there suggest a great service dept. in the Houston area. Thanks for the welcome. Ive been reading post on this site since you'll began, although this is the first time I actually registered.
    Thanks again, Jimmy from Houston

  4. #4
    Flynfox's Avatar
    Join Date
    Aug 2006
    Location
    Sunny SC
    Posts
    682
    james06rxp,

    If you can't hear the SC then the ceramic washers probably took a dive. Good luck man & let us know what you find out.

    Oh and welcome to the forum. Everybody here is great and very helpful.
    Last edited by Flynfox; 02-26-2007 at 01:46 AM.

  5. #5
    if some one suck up something through the pump it might've taken the wear ring out sounds like u need a new wear ring, don't run the ski any more but if ur ski would only turn 6800 rpm the the s/c clutches r probley gone easy way 2 chek is take off the air intake hose going 2 the s/c take ur finger & try 2 spin the s/c wheel if u can turn it by hand the the s/c clutches r gone

  6. #6
    I Took the hose off the back of super charger (like you said) and, I can spin it like a top. So I guess I bought somebody's craft that probably was on the verge of a sc failure. I was wandering why I wasn't too impressed with the over all bottom end power. Everybody told me it pulls your arms hard I never felt any thing like that. The top end on the first day was fine, but out of the whole my gpr1300 could maybe beat it.

  7. #7
    BlaZinMJ's Avatar
    Join Date
    Aug 2006
    Location
    Wyomissing, PA/Ocean City, MD
    Posts
    1,063
    now all you can do is take it to a very reputable dealer and make sure they replace everything and clean out the oil pumps etc.......when their done, replace the ceramic washers with green hulk's metal washers for the 06' style supercharger(look for the link in my sig).....tht will make your rxp bulletproof

  8. #8
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    Quote Originally Posted by BlaZinMJ View Post
    that will make your rxp bulletproof
    don't make promises you can't keep ... i prefer the term "slightly less impermeable"

  9. #9
    cbrich's Avatar
    Join Date
    Nov 2006
    Location
    Around Lake Travis
    Posts
    1,374
    +1
    1
    That sucks I just took my RXT to the dealer to get the 10 hr service done. I replaced the ceramic washers, with steel ones at 2 hr.

    Buy the extended warranty and get it fixed.

  10. #10
    BlaZinMJ's Avatar
    Join Date
    Aug 2006
    Location
    Wyomissing, PA/Ocean City, MD
    Posts
    1,063
    Quote Originally Posted by Shibby1485 View Post
    don't make promises you can't keep ... i prefer the term "slightly less impermeable"
    thats what i meant

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2013 Yamaha FZS. I think my supercharger clutch finally failed.
    By GASKING in forum Yamaha PWC Performance (4-stroke)
    Replies: 11
    Last Post: 10-31-2016, 11:17 AM
  2. Replies: 25
    Last Post: 04-06-2014, 08:56 PM
  3. Is my super charger gone already?
    By andersonn in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 07-11-2010, 10:07 AM
  4. OEM Supercharger clutch washer failure on my RXT-X
    By heckie in forum 4-Tec Performance
    Replies: 95
    Last Post: 03-25-2009, 02:59 AM
  5. I receved my new supercharger clutch kit today.
    By Krazy-K in forum 4-Tec Performance
    Replies: 16
    Last Post: 10-21-2005, 07:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •