Results 1 to 5 of 5
  1. #1

    Join Date
    Aug 2011
    Location
    Mt. Vernon Illinois 62898
    Posts
    113

    1200 txi flame sensor question please?

    I have a 2002 TXI that I am going through and getting it back on the water. I am including a photo of my flame sensor that has been deformed by the air cleaner box or lid. I will fix the lid or box so it wont happen again but was wondering if I need to replace the sensor as it looks funny?

    What is its function on the ski?

    Does anybody know the part number and maybe a parts source?

    Thanks...

    Click image for larger version. 

Name:	photo.jpg 
Views:	59 
Size:	76.4 KB 
ID:	300646
    Last edited by K447; 05-09-2013 at 01:01 PM.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    That is the air temp sensor that feeds the EMM. Trim the flame arrestor cover plastic web so it clears the sensor.

    You can find the part number via the Polaris Industries parts web site. Details via my signature links, along with parts sources.

    Polaris issued an update which adds a plastic spacer to lower the temp sensor, plus two longer screws. Trimming the plastic cover does work, of course.

  3. #3

    Join Date
    Aug 2011
    Location
    Mt. Vernon Illinois 62898
    Posts
    113
    What does the sensor actually do? Whats its function? Does mine look unusable? Thanks...

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,574
    +1
    1,272
    Quote Originally Posted by jdjd View Post
    What does the sensor actually do? Whats its function? Does mine look unusable? Thanks...
    It senses the air temperature going into the engine and tells the EMM what the air temperature is. The EMM uses the air temperature info as part of the calculation to adjust the amount of fuel being injected.

    If your sensor is internally damaged or contaminated by oil then it should be replaced. You can check the ohms to see if the reading is wildly out of spec, but the safe approach is to install a new sensor.

  5. #5

    Join Date
    Aug 2011
    Location
    Mt. Vernon Illinois 62898
    Posts
    113
    Thanks for your help.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 TXI 1200 questions please?
    By jdjd in forum Polaris PWC Performance
    Replies: 6
    Last Post: 04-30-2013, 08:49 PM
  2. 2002 virage 1200 txi please help!!!!
    By Dauer33 in forum Polaris Open Discussion
    Replies: 16
    Last Post: 03-28-2012, 07:45 PM
  3. 2001 xlt 1200 Exhaust sensor question
    By tchies in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 05-28-2011, 05:32 PM
  4. 2002 Polaris TXI 1200 Won't Start Help please.
    By deepsouth in forum Polaris Open Discussion
    Replies: 4
    Last Post: 03-04-2011, 06:16 PM
  5. RXP Knock sensor question/ Low RPMs. Please help!
    By ADHDave in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-21-2010, 06:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •