Results 1 to 4 of 4

Thread: 95sl 750

  1. #1

    95sl 750

    I replaced the gas and it ran great about a month ago when I took it out. It has rained and snowed since then. Just took it out a little bit ago and it didn't want to go very fast. I took it out of the water and put it back on the trailer. Opened up the seat and noticed the red washer was almost floating to the top which means water in the gas. I drained it and put it back in the water just on the trailer and started it back up. Spit and spuddered for a moment then seemed to run a lot better.

    How does water get into the gas? Crack in the cap? Can it back flow from the engine?


  2. #2
    yes cheak your cap and filler neck make sure its not cracked or see if there a rubber seal under the cap, u can take the reserve hose off the fuel regulator and blow into the hose make sure ur regulator off and if u can hear air comming out of the neck it has to be cracked somewhere there.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,575
    +1
    1,272
    Quote Originally Posted by luther.douglas View Post
    yes check your cap and filler neck make sure its not cracked or see if there a rubber seal under the cap,

    u can take the reserve hose off the fuel regulator and blow into the hose make sure ur regulator off and if u can hear air comming out of the neck it has to be cracked somewhere there.
    Well, it might be more straightforward to remove the fuel tank vent hose from the top of the fuel tank. Make sure the fuel selector valve is turned OFF.

    Apply a few PSI to the fuel tank via the vent nipple. Do not over pressurize the fuel tank. Now you can listen and look for air leaks. Some soapy water in a spray bottle can help you locate leaks. Just spray it and look for bubbles foaming up at the leaks.

    My signature links include some info on upgrading to the newer style fuel filler cap and filler neck.
    Last edited by K447; 05-10-2013 at 11:25 PM. Reason: Vent hose for pressure testing fuel tank, not return hose

  4. #4
    Ok. Thanks . I will check it over next week.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95sl 750
    By RiverRat19405 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 08-14-2007, 11:56 PM
  2. 95sl 750
    By RiverRat19405 in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-14-2007, 10:04 PM
  3. Just purchased a 1995 SLT 750.. Questions
    By daveo13 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 09-08-2006, 03:59 PM
  4. My 750 project continued
    By ph2ocraft in forum Polaris PWC Performance
    Replies: 4
    Last Post: 08-31-2006, 06:23 PM
  5. Al's New SL 750 Dash Panel
    By CrazyA in forum Polaris PWC Performance
    Replies: 17
    Last Post: 08-31-2006, 03:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •