Results 1 to 3 of 3
  1. #1

    sho valve problems

    In the midst of rebuilding my motor and I knew everything had gone too well so far. Pulled all my valve springs today to replace the seals , springs and check out my valves. A bunch of the valves wont come out....some are chewed up where the lower part of the lock sits. Sigh. Ill have to de burr the tops to get them through the guides without trashing them. I guess I need to find out if riva has valves in stock. Any reason the aftermarket riva valves wont work with my rd springs? I understand they require there own locks. Or I just go oem again, depends on availability....
    Then more machine shop time....yay. im guessing they will just have to clean up and lap the seats for the new valves.

    Valve float to blame? Ski had an 8600 rpm limiter and was propped for 8200.

  2. #2
    Join Date
    Nov 2005
    valve float is not to blame you will never float a valve at 8200 rpm. Get some sand paper and sand the burr around the valve and the valve will come right out.

  3. #3
    Upon closer inspection the only visible wear is about a 1/4 inch belowbwhere the locks sit on the stem. All my exhaust valves came out easy, only 1 intake valve will come out with issue. Currently sanding and removing valves.

    Tempted to run them as is...but hesitant at the same time. My guess is the wear is from the valve stem pushing to one side or the other at max lift and causing wear against the top edge of the valve guide. Only the exhaust valves show wear. Picture shows the two worst valves.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	uploadfromtaptalk1368216475764.jpg 
Views:	42 
Size:	68.3 KB 
ID:	300734  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SHO driveline problem?
    By Antiguan FZR in forum Yamaha PWC Performance (4-stroke)
    Replies: 26
    Last Post: 10-06-2009, 04:31 PM
  2. think this is a power valve problem?
    By wakewhornc in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 08-29-2008, 08:49 AM
  3. SHO production problem with starter?
    By slabo in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 06-02-2008, 05:51 PM
  4. sho driveshaft problem
    By bm27 in forum Yamaha PWC Performance (4-stroke)
    Replies: 15
    Last Post: 03-07-2008, 07:03 PM
  5. HELP..04 xlt 1200 22 hrs..power valves problem
    By db3055 in forum Yamaha How To & FAQs
    Replies: 4
    Last Post: 08-16-2007, 09:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts