Results 1 to 10 of 10
  1. #1

    New To Board - First Ride Yesterday

    First, thanks to the board for the tip on checking the exhaust clamps - fortunately mine were tight.

    First ride: I did not try any top speed runs until 2.5 hours. With the buzzer about to go off (seconds after my run) I hit 65.8 with my 205 lb. weight and 62 F air temp - that seems good to me. I have not yet cleaned the ride plate area of the silicone.

    I did have serious cavitation from any speed below about 20 mph - even when bending my upper body over the bars. The ski's nose stayed down but the cavitation was severe - worse from a stop.

    I am quite experienced racing and working on skis so I am fully capable of cleaning the rubber seal mentioned elsewhere in this forum but would prefer to let them fix the problem to avoid finger pointing if it turns out to be something else. Any idea if dealers generally are aware of how to fix this issue?

    Thanks in advance.


  2. #2
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Hey Dave WELCOME to the Green Hulk Forums.
    Congrats on your new ride. Trivial, but what color did you purchase??
    I talked with my dealer and they don't even have an Ultra yet.

  3. #3
    Welcome Dave


    Im not sure about your dealer but mine here in Fl is awsome. Can have your service department call down here and get the steps.
    If you try and tell em how to do it youll probably gets smiles and head nods then when you turn around out comes the bird.

  4. #4
    Thanks Skip - I will let you know if they seem unsure of themselves.

    ph2ocraft - it is blue/silver. For anyone interested there was a red one available at D&S Kawasaki in Arlington Texas last week.

  5. #5

    Join Date
    Sep 2006
    Location
    S. Florida
    Posts
    508
    Quote Originally Posted by DaveF View Post
    First, thanks to the board for the tip on checking the exhaust clamps - fortunately mine were tight.

    First ride: I did not try any top speed runs until 2.5 hours. With the buzzer about to go off (seconds after my run) I hit 65.8 with my 205 lb. weight and 62 F air temp - that seems good to me. I have not yet cleaned the ride plate area of the silicone.

    I did have serious cavitation from any speed below about 20 mph - even when bending my upper body over the bars. The ski's nose stayed down but the cavitation was severe - worse from a stop.

    I am quite experienced racing and working on skis so I am fully capable of cleaning the rubber seal mentioned elsewhere in this forum but would prefer to let them fix the problem to avoid finger pointing if it turns out to be something else. Any idea if dealers generally are aware of how to fix this issue?

    Thanks in advance.
    Welcome to the forum and congrats on your new ski. I would love to get your feedback when/if you get the cavitation issue resolved. It will be helpful information to others on the board.

    Curtis

  6. #6
    jscottmsc's Avatar
    Join Date
    Sep 2006
    Location
    Charlotte, NC
    Posts
    223
    Quote Originally Posted by DaveF View Post
    For anyone interested there was a red one available at D&S Kawasaki last week.
    Hey DaveF,

    I bought (in 1996) a Kawasaki 1100ZXI from D&S Cycle in Arlington Texas. I was living in Plano at the time.

    Scott

  7. #7
    Tractorak's Avatar
    Join Date
    Feb 2007
    Location
    Anchorage,AK
    Posts
    5

    Lucky Buggers

    My Ultra is sitting at the dealership the -20 degree weather puts a damper on the riding. I Wanted the red but our dealership only got in 3 and someone had already bought the one red and the other blue. I won't be able to put the beauty in the lake till the end of May. I guess the good point is that the awesome members on this site will have sacrificed many hours and tons of loot on the R&D. Much appreciated from the Great White North.
    Last edited by Tractorak; 02-27-2007 at 02:56 AM. Reason: Added content.

  8. #8
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    Welcome Tractor.

    I saw the Blue/silver one on Saturday for the first time ON THE WATER. It looks much better on the water. I think when it gets wet, it seems to take on a deeper color.

  9. #9

    Join Date
    Oct 2006
    Location
    melrose ma
    Posts
    411

    pump stuffers.....from R&D

    i looked on the r&d web sight and there ready.....perhaps thay might solve your dalema.

  10. #10
    Hi Dave, how far did you ride in the 2.5 hour period?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New Ultra 310 first ride videos
    By John Arnaut in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 12-02-2013, 11:57 AM
  2. 96 Wave Venture New to me First PWC
    By kuleinc in forum Yamaha Old School Skis
    Replies: 29
    Last Post: 10-05-2013, 01:13 AM
  3. Replies: 2
    Last Post: 02-21-2013, 12:18 AM
  4. 2001 XLT 1200 - New to me. First Steps?
    By D-Sect in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 06-08-2010, 10:57 AM
  5. First Ride Yesterday
    By bikerstyle in forum Yamaha Open Discussion
    Replies: 3
    Last Post: 02-06-2008, 02:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •