Results 1 to 6 of 6
  1. #1
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,771
    +1
    129

    '02 GTX 951 DI stall out issue maybe fuel problem

    This poor woman has had this machine at every place around including the stealership twice. Now I'm trying to figure it out. For starters it has 224 hours and was still wearing it's original fuel filter. I changed it out and it starts right up and seems to be running just fine. Fuel pressure while running is only about 102-103.and it drops to about 100 by 3500rpm and right at about 5500 rpm drops again to 93-95. For the most part it ran out just fine but I could only get 6680 RPMs out of it and a little surging. I'm guessing the RAVEs need cleaned out. I'm wondering if the clogged fuel filter could have weakened the pump. Does the pressure fall out like this normally? Also after about 50 minutes of mostly 6000-6500 RPM riding it just stalled. It started right back up and went for about 2 minutes and died again. Then started and died right away twice. Then I loaded it onto the trailer since I happen to be right there anyway and started it up(still in the water) and ran it at 6200-6500 rpm for several minutes and it was just fine. She had stated that before it totally quit it would run for 45-60 minutes and shut down. When this happened I had ran it exactly 55 minutes. What do you guys think about this. I'm leaning towards a bad fuel pump getting hot and shutting down or possibly a loose connection somewhere. Motor temp was fine and air pump was only slightly warmer than the engine.


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,518
    +1
    1,266
    any read on error codes past or present?

    224 hours is a bit long in tooth for a 951.

    was the filter clogged when you took it out?

    Did you check the sock on the fuel pick up?

    I'd be looking at the fuel pump..but that's a really expensive bit

  3. #3
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,771
    +1
    129
    Before I even started with the fuel filter I only had about 95psi past the filter. That's why I started there. I haven't cut the filter open but I can feel resistance just by blowing through it by mouth. I have not pulled the pump to check the sock yet. Has anybody heard of the wiring from the pump to the connector going bad?

  4. #4
    A DI is not like a lot of FI systems that degrade in performance as fuel pressure drops. The DI hits a tipping point somewhere between 90 and 100 PSI, once you drop to this point, it shuts down. You have to have good solid 100+ PSI at all times. It sounds like the pump is toast. Pull it first to check the sock. There are reasonably cheap replacement pump cartridges that that are a lot cheaper than the OE pump, but you have to do some mods to get it to work.

  5. #5
    Myself's Avatar
    Join Date
    May 2007
    Location
    North Central Arkansas
    Posts
    2,771
    +1
    129
    Yes, I've read about the replacements and that's probably what we'll do. Also with the hours I was suspecting the pump. I'll check the sock and test the pump outside of the tank to see what it does but pressure starts dropping shortly after idle. Also at an idle I usually have a badly fluttering pressure gauge. I tested my gauge on my heat pump system and get no flutter so that variation must also be coming from the pump.

  6. #6
    The other thing to watch out for is there are specs for pressure, but no specs or tests for volume. You could have a pump that puts out the spec'd pressure by using the test in the manual, but when you run it, the pump cannot keep the pressure under volume, so the pressure drops when you ride it. This could be really aggravating to diagnose.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB 99-02 GTX 951 Carb MPEM
    By scottbaty in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 06-12-2010, 11:51 AM
  2. GTX 951 DI only 4750 RPM.
    By Myself in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-03-2010, 09:52 PM
  3. 2001 GTX 951-DI info
    By TheBlueMartin in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-10-2009, 10:58 AM
  4. Parting out SeaDoo GTX 951 DI
    By gofast476 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 09-15-2008, 06:38 PM
  5. 02' GTX 951 life expectancy?
    By VetteTech81 in forum 2-Stroke Performance
    Replies: 15
    Last Post: 05-11-2008, 09:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •