Results 1 to 9 of 9
  1. #1
    Bay Rat cvbdrew's Avatar
    Join Date
    Oct 2009
    Location
    Irondequiot Bay, NY
    Posts
    218
    +1
    1

    Ultra 250x cavitating out of the hole

    I picked up 2 Ultras this spring and one of them cavitates real bad getting up on plane. Once, it's hooked up, it runs just as strong and fast as the other one. However, the other ski just rips right out of the water with no cavitation. These skis had 3 hours on them when I bought em. The one cavitating has 12hrs now. What should I be looking for to fix this problem? I'm fairly new when it comes to jet pumps, even though I've had 5 skis. I've never had to mess with a pump before.

    Thanks in advance,
    Drew


  2. #2
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    basically if you can see an airgap between the prop and liner theres your problem, also just check if prop isn't damaged or something stuck in the vanes, actually if they are 2007 models the pump tunnel had excess amounts of silicon applied causing the said issue

  3. #3
    ImpactSportsTV's Avatar
    Join Date
    Apr 2009
    Location
    San Clemente, CA
    Posts
    173
    +1
    16
    Quote Originally Posted by nicjak View Post
    basically if you can see an airgap between the prop and liner theres your problem, also just check if prop isn't damaged or something stuck in the vanes, actually if they are 2007 models the pump tunnel had excess amounts of silicon applied causing the said issue
    +1 on everything nicjak said and I would add that the silicone caulking job for the ride plate was terrible as I received it on my '07, I don't know if it was bad from from the factory or a dealer botched it, but the bead across the rear edge was too far forward to make contact, leaving a 1/8" gap to feed air straight to the front of the pump. Once that was corrected, the cavitation was gone on mine.

  4. #4
    Bay Rat cvbdrew's Avatar
    Join Date
    Oct 2009
    Location
    Irondequiot Bay, NY
    Posts
    218
    +1
    1
    Thanks guys... sick 300's BTW. That'll be my next ski! Should I remove the old silicon and re-apply new stuff?(If that's my problem) If so, any recommendations on brand or type of silicone?

  5. #5
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    you should be able to just trim it with a knife if thats the problem, if you fel the need to use more use marine grade.

  6. #6
    ImpactSportsTV's Avatar
    Join Date
    Apr 2009
    Location
    San Clemente, CA
    Posts
    173
    +1
    16
    Quote Originally Posted by cvbdrew View Post
    Should I remove the old silicon and re-apply new stuff?(If that's my problem)
    For me, it was just a matter of removing the ride plate and reinstalling it with good marine-grade silicone in the proper places so that it actually sealed, especially inside the rear edge. This may or may not be the issue for you, but it made a night-and-day difference for me.

    best of luck with it!

  7. #7
    Bay Rat cvbdrew's Avatar
    Join Date
    Oct 2009
    Location
    Irondequiot Bay, NY
    Posts
    218
    +1
    1
    Turns out this was the problem. Previous owner must have sucked something bad through the pump because all 3 blades were bent over. A new Solas Concord has been ordered and should arrive soon!

    Click image for larger version. 

Name:	1013070_10151570509158710_308674989_n.jpg 
Views:	109 
Size:	40.7 KB 
ID:	305422

  8. #8
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    very fixable with a grinder/file smooth the edges and good to go

  9. #9
    Bay Rat cvbdrew's Avatar
    Join Date
    Oct 2009
    Location
    Irondequiot Bay, NY
    Posts
    218
    +1
    1
    Quote Originally Posted by nicjak View Post
    very fixable with a grinder/file smooth the edges and good to go
    I'll hang on to it for back up, but I'm putting a new Solas on it.

  10. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2008 RXP CAVITATION out of the hole and hitting rev limiter
    By eschanen85 in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-18-2013, 01:00 PM
  2. Ultra 150 Slow out of the hole?
    By Shan in forum Kawasaki PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-10-2010, 06:46 AM
  3. Need help cavitation out of the hole
    By andre in forum 4-Tec Performance
    Replies: 19
    Last Post: 11-02-2008, 08:49 AM
  4. FX SHO Cavitation out of the hole
    By LS2000 Cop in forum Yamaha PWC Performance (4-stroke)
    Replies: 0
    Last Post: 10-06-2008, 07:19 PM
  5. cavitation out of the hole
    By daverxp4 in forum 4-Tec Performance
    Replies: 36
    Last Post: 05-28-2008, 07:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •