Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Join Date
    Aug 2011
    Location
    goldsboro, nc
    Posts
    34

    Yamaha GP760 Electrical / Ignition trouble

    Yamaha GP 760 1998


    When I push the green button to start nothing happens. I have read every post on every forum related to this so I have come to greenhulk to see if someone might know.

    I found on some forum to do this *what is shown in the attached picture* (paper clip connecting the red and brown wires that come from the start/killswitch box on the handle bars) when I do this it will start. Otherwise if I just hit the green button absolutely nothing happens.

    Click image for larger version. 

Name:	20130517_185351.jpg 
Views:	100 
Size:	58.0 KB 
ID:	301331

    I have disassembled the start/killswitch box on the handle bar and thoroughly inspected each of the 3 buttons (start, kill switch, lanyard pull out safety kill switch) and they all appear to be in great working order.


  2. #2
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,326
    +1
    49
    Basically what the test you have done with the paper clip is telling you is that you have a faulty start switch. the green button or a bad wire coming from the start circuit (green button)

  3. #3
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,529
    +1
    190
    i have one box you can use , just take care shipping , it will fix your problem.

  4. #4

    Join Date
    Aug 2011
    Location
    goldsboro, nc
    Posts
    34
    Thank you so much for being so generous! I will gladly pay for shipping, would you like me to send through pay pal?

    Just to clarify are you talking about this or that (the entire box, or just one of the individual start/kill switch buttons)?


    Click image for larger version. 

Name:	this.JPG 
Views:	49 
Size:	46.2 KB 
ID:	301340Click image for larger version. 

Name:	that.jpg 
Views:	60 
Size:	86.9 KB 
ID:	301341

  5. #5
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,529
    +1
    190
    the whole box like on the first picture.

  6. +1 by:


  7. #6

    Join Date
    Aug 2011
    Location
    goldsboro, nc
    Posts
    34
    Wow that would be awesome man! How much and how would you like me to send it?

  8. #7
    Clean ur ss it's typically the top left one in ur pic. Pull that one out and take out the 4 screws pull the cover off be careful thers 2 springs and 2 u shape brass pieces clean it really good I typically use 320 sand paper the dielectric grease. Reinstall. The black white wire one once in a while is a problem also just unscrew the cap on to there will be a spring and a plate w brass and 2 contact points in the middle clean it same way

  9. #8
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,528
    +1
    1,273
    the switch is worn out. repairs are a total waste of time. It's just not a good design.

    you might get a few more days out if it but that's it.

    Take my word on this one, been around it a few times too many.

  10. #9
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,529
    +1
    190
    Quote Originally Posted by nmpeter View Post
    the switch is worn out. repairs are a total waste of time. It's just not a good design.

    you might get a few more days out if it but that's it.

    Take my word on this one, been around it a few times too many.
    totally agree with you .

  11. #10
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,529
    +1
    190
    Quote Originally Posted by chuckcanavi View Post
    Wow that would be awesome man! How much and how would you like me to send it?
    send me a pm with your number and address. it will go out to you on Monday. just replace the whole thing.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Yamaha 1100 Electrical/Ignition Parts
    By ac30treb in forum Yamaha Classifieds
    Replies: 2
    Last Post: 05-21-2010, 12:14 AM
  2. Parting Yamaha GP760 -nice, freshwater ski
    By jetmaniac in forum Yamaha Classifieds
    Replies: 12
    Last Post: 10-01-2009, 07:57 AM
  3. Sl900 ignition trouble
    By RIDERSRUNMOTORSPORTS in forum Polaris Open Discussion
    Replies: 6
    Last Post: 08-31-2009, 07:47 PM
  4. Engine for 2000 Yamaha GP760
    By repairman7591 in forum Yamaha Classifieds
    Replies: 0
    Last Post: 07-27-2008, 07:54 PM
  5. Yamaha GP760
    By cricket1962 in forum Yamaha Old School Skis
    Replies: 6
    Last Post: 08-15-2007, 03:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •