Results 1 to 8 of 8
  1. #1

    03 polaris won't start

    So, I checked the carb settings, checked the spark, checked the compression (125 p.s.i. both cyl.), has fuel and oil, has spring gas pump, worked well last Tuesday no problems. Starter engages and turns the crank, but it will not continue running. Its getting gas in the barrel. I've run out of ideas...03 polaris freedom
    Last edited by mike6345; 05-18-2013 at 02:24 AM.


  2. #2
    Banned User
    Join Date
    Jun 2010
    Location
    Milwaukee WI
    Posts
    16,708
    +1
    1,324
    Check your battery with a volt meter. It MUST deliver at least 10.6 volts while cranking or it will not fire the plugs. With the plugs out, it will show spark, but when you put them back in, they won't spark if the battery isn't strong enough.

  3. #3
    Quote Originally Posted by BryanP View Post
    Check your battery with a volt meter. It MUST deliver at least 10.6 volts while cranking or it will not fire the plugs. With the plugs out, it will show spark, but when you put them back in, they won't spark if the battery isn't strong enough.
    It Gets 11.2 v

  4. #4
    David Drkvampire2001's Avatar
    Join Date
    Jul 2011
    Location
    Edgerton, Wisconsin, United States
    Posts
    2,857
    +1
    30
    Quote Originally Posted by mike6345 View Post
    Quote Originally Posted by BryanP View Post
    Check your battery with a volt meter. It MUST deliver at least 10.6 volts while cranking or it will not fire the plugs. With the plugs out, it will show spark, but when you put them back in, they won't spark if the battery isn't strong enough.
    It Gets 11.2 v
    was that with a volt meter on the battery? or the MFD?

  5. #5
    From batt to crank case while cranking v drop was 1.36 v

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    Quote Originally Posted by mike6345 View Post
    From batt to crank case while cranking voltage drop was 1.36 v
    From battery negative post, I assume.

    That voltage drop seems a bit much. Remove the grounding bolt from the engine. Clean the hole threads, the bolt threads, the engine case where it clamps down, and the cable ends. You want clean metal to metal contact. Reassemble without thread locker or dielectric grease (for now).

    See if voltages improve when cranking.

  7. #7
    The cylinders were flooded,

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,595
    +1
    1,276
    Quote Originally Posted by mike6345 View Post
    The cylinders were flooded,
    With what?

    If gasoline, did you leave the fuel selector valve in the ON position while it was sitting?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 03 Virage won't start hot
    By Chester in forum Polaris Open Discussion
    Replies: 2
    Last Post: 08-11-2013, 12:19 PM
  2. 03 polaris genesis not starting :(
    By fuji600 in forum Polaris Open Discussion
    Replies: 17
    Last Post: 06-22-2009, 06:06 AM
  3. 2002 Polaris about 40hr's won't start?
    By polaris42 in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-02-2007, 07:56 PM
  4. 2002 Polaris Virage TXi.. HELP!!! WON'T START
    By fitch615 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-05-2007, 04:31 PM
  5. 2001 Polaris Genesis won't start
    By Blink in forum Polaris How To & FAQs
    Replies: 11
    Last Post: 01-11-2007, 09:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •