Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17

Thread: Coolant issue??

  1. #1
    ajrunke's Avatar
    Join Date
    May 2008
    Location
    Oshkosh, WI
    Posts
    196
    +1
    1

    Coolant issue??

    Hi all.

    I just got back from my 4th trip this year on my 06 RXT. I was out for only an hour after I smelled what I thought was burning coolant. I got a quick whiff of it, but then it was gone. I immediately stopped and I popped the seat off and I could hear what sounded like boiling coolant. There was a small amount of white smoke / vapor coming from the hose attatched to the J Pipe, but this smoke/vapor had zero scent. There were no warnings / high temp signals on the dash. I brought it home and checked all the hoses. Everything is secure. The only thing I can think of is that I recently pulled the super charger and out of a moment of stupidity, I popped the coolant hose off for a split second and a very little amount leaked out. Could I have air in the coolant lines now? Anyone have any thoughts?

    Thanks, and I appreciate all input.


  2. #2

    Join Date
    May 2012
    Location
    McKinney Texas
    Posts
    140
    +1
    5
    As someone that is mechanically inclined and paranoid I will sometimes smell the same thing, and freak out like you did. I find that most times it is just an random smell. Only once have I actually found a lose hose.

  3. #3
    Madzooki's Avatar
    Join Date
    Jun 2012
    Location
    Corpus Christi, Texas
    Posts
    132
    +1
    2
    It could have just been the coolant burning off of the engine that spilled. Is your coolant bottle low?

  4. #4
    ajrunke's Avatar
    Join Date
    May 2008
    Location
    Oshkosh, WI
    Posts
    196
    +1
    1
    Coolant level is correct...I'm going to test it here on the water shortly. I can't see anything wrong. The bubbling/boiling sound is worrisome.

  5. #5
    do you have any black particles floating in the coolant

  6. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    A boiling jug is a sign that your coming up to some issues.

    It shouldn't boil out water.

  7. #7
    CHAD IBADTON's Avatar
    Join Date
    Jul 2008
    Location
    on lake Harding AL
    Posts
    558
    +1
    34
    Sounds like stuck thermo how long has it been sense you road it and is it stock thermo?

  8. #8
    warsawspeedfreak's Avatar
    Join Date
    Jan 2010
    Location
    Tinley Park, IL
    Posts
    369
    +1
    19
    Quote Originally Posted by ajrunke View Post
    Coolant level is correct...I'm going to test it here on the water shortly. I can't see anything wrong. The bubbling/boiling sound is worrisome.
    Where is the boiling sound coming from? On hot days you can sometimes here the water in the water box boiling after a hard run...

  9. #9
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    6,378
    +1
    981
    Pressure check the cap.

  10. #10
    speeddemon's Avatar
    Join Date
    Dec 2005
    Location
    Lancaster, Pennsylvania, United States
    Posts
    116
    +1
    1
    Since you guys are talking about coolant . I have a 2008 RXP-X with 116 hrs & having issues with antifreeze leaking into the hull ,but all the hoses are connected .
    My dad thinks my thermostat was sticking & that it boiled out ! I took my first run of the season last Friday . I would do a run half throttle & come back & seemed to be OK ! Then my last run I opened her up & when I got back I could see the resivor went completely empty ! I have been trying to figure out this problem @ the end of summer of last yr & still don't have a solution or fix yet ! Could someone chime in on this problem ? Other than that my ski runs like a raped APE ! LOL

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 06 rxp sea doo coolant issue
    By Frankdees in forum 4-Tec Performance
    Replies: 8
    Last Post: 09-06-2012, 12:35 PM
  2. 2006 Seadoo RXP Coolant Issue
    By anbeeson in forum 4-Tec Performance
    Replies: 14
    Last Post: 09-24-2011, 02:59 AM
  3. coolant issue
    By monaroman76 in forum 4-Tec Performance
    Replies: 10
    Last Post: 10-23-2010, 08:43 AM
  4. Help! Weird puking coolant issue!!
    By FreakRXP1200 in forum 4-Tec Performance
    Replies: 26
    Last Post: 04-14-2009, 03:52 AM
  5. coolant issue
    By FLArxp 850 in forum 4-Tec Performance
    Replies: 1
    Last Post: 06-07-2008, 01:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •