Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    Ultra 300 hesitation

    Hi guys I'm having problems with my 300, the ski seems to be hitting some kind of limiter when I'm out riding it seems like its worse after 30 mins or so. It's running fine and then it feels like the motor goes flat and revs to around 6000 it lasts for about a second and then clears and goes again and then will do it again but not all the time, I notice it most when I'm offshore in the rough and I let off and then apply the power again but it's just not constantly doing it.today I did a standing start to flat out and it did it from the start then cleared and topped out at 7360rpm. Any ideas what's going on? Ski is stock no scom and no washers.


  2. #2
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Change your plugs. Check your sc belt

  3. #3
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    he also had troubles with his speedo wheel pickup wires so that maybe an issue also, to much going on with this ski he needs to sort it all out..

  4. #4
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Quote Originally Posted by nicjak View Post
    he also had troubles with his speedo wheel pickup wires so that maybe an issue also, to much going on with this ski he needs to sort it all out..
    Ahhhh yea that could def be a cause. Usually helps when they give all the info lol

  5. #5
    Speedo cable repaired last week so no issue there, nothing else going on with this ski it's stock

  6. #6
    DoubleTap's Avatar
    Join Date
    Jun 2011
    Location
    Cape Coral, FL
    Posts
    195
    +1
    60
    I've been having a similar issue. After a day on the water when I'm coming back in.
    Hit the trottle hard from a stop and it stalls out for about a 1/2 second then hits hard again to top speed. If you ease into it no stall. It has to be full trottle after the ski is been run for a long time. My ski has 167 hours bone stock.

  7. #7
    That sounds very similar to mine, I have a suspicion it may be supercharger belt the ski only has 52 hours but I've been looking closely at hoses etc and have noticed water running out the corrugated plastic shield around the hose that comes off the catch can so my theory is that water is running doen onto the belt, I'm going to continue checking all hoses and also have replaced exhaust filter and plugs and then gonna try again, I think your issue will be worn supercharger belt at that many hours.

  8. #8
    DoubleTap's Avatar
    Join Date
    Jun 2011
    Location
    Cape Coral, FL
    Posts
    195
    +1
    60
    I think you right with the super charger belt. Exhaust filter and plugs are new on my ski. I can also see rubber powder around the pulleys. I do get lots of water in my bilge when it's rough. The belt could also be getting wet and slipping?

  9. #9
    Yea deffo go with the belt do you know where your waters coming in?

  10. #10
    DoubleTap's Avatar
    Join Date
    Jun 2011
    Location
    Cape Coral, FL
    Posts
    195
    +1
    60
    The boat can sit in the water and be dry. If run in smooth water it's also dry. Has to be when the bow goes under.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2011 Mountain Motorsports Ultra 300 First Pics
    By farthingracing in forum Kawasaki PWC Performance (4-stroke)
    Replies: 195
    Last Post: 05-19-2011, 11:55 PM
  2. New Riva Ultra 300/260/250 Byapss Upgrade Kit
    By Green Hulk in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 04-18-2011, 03:32 PM
  3. New RIVA Ultra 300 Power Filter Kit
    By Green Hulk in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 04-18-2011, 03:30 PM
  4. Ultra 300 X Owners Manual Lube pump bearings and seals ??????
    By Kevan in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 04-07-2011, 11:08 PM
  5. ULTRA 300 performance parts
    By KawaHead in forum Kawasaki PWC Performance (4-stroke)
    Replies: 2
    Last Post: 03-11-2011, 07:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •