Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 31
  1. #1
    Rt-HemiBoY's Avatar
    Join Date
    Mar 2010
    Location
    HiAleAH-MiAMi--FL
    Posts
    1,315
    +1
    24

    !!2012 rxpx Carbon Seal???

    Had anybody experienced any failures to the carbon seals on this ski mines have 38hrs today when riding in the ocean i noticed i was getting some water inside the hull i didnt see any hose leaking or anithing could it be that its leaking???? How could i do test or check if its that carbon seal is bad??? thanks for any replys..


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Normally when a carbon seal leaks its a lot of water.

    I've had a few carbon seals go on different skis.
    It's usually a couple minutes and the hull is full.
    Your water is probably not from the carbon seal.

  3. #3
    Rt-HemiBoY's Avatar
    Join Date
    Mar 2010
    Location
    HiAleAH-MiAMi--FL
    Posts
    1,315
    +1
    24
    Quote Originally Posted by wotxxxsd View Post
    Normally when a carbon seal leaks its a lot of water.

    I've had a few carbon seals go on different skis.
    It's usually a couple minutes and the hull is full.
    Your water is probably not from the carbon seal.
    Thanks i try to keep looking for the leak also i did notice that even if the ski was off was getting water inside...

  4. #4
    Olomana's Avatar
    Join Date
    Jan 2011
    Location
    Tahiti, French Polynesia
    Posts
    1,414
    +1
    76
    You will have some cavitation as well if your carbon seal is a goner.
    check the resonator maybe?
    Intercooler cooling hose leaking?

  5. #5
    big john's Avatar
    Join Date
    Sep 2010
    Location
    Cocoa Beach, Florida, United States
    Posts
    3,395
    +1
    598
    the carbon seal and its alignment is a huge problem on late model sea doo's, dollars to donuts its shot

  6. #6
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,559
    +1
    948
    You do have the correct prop installed right? If its aftermarket and not setback you will get leaks

  7. #7
    Rt-HemiBoY's Avatar
    Join Date
    Mar 2010
    Location
    HiAleAH-MiAMi--FL
    Posts
    1,315
    +1
    24
    Quote Originally Posted by seadoo02xp View Post
    You do have the correct prop installed right? If its aftermarket and not setback you will get leaks
    Yes i have the solas srz 15-20 installed been there for a couple hours now

  8. #8
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,559
    +1
    948
    How much water are you getting in there? Could it just be water that splashed I through the front vents

  9. #9
    Rt-HemiBoY's Avatar
    Join Date
    Mar 2010
    Location
    HiAleAH-MiAMi--FL
    Posts
    1,315
    +1
    24
    Quote Originally Posted by seadoo02xp View Post
    How much water are you getting in there? Could it just be water that splashed I through the front vents
    Humnn no it was actually a good amount and even with the ski off i see water coming in but its all weird....then i turn it on and notice even more coming in......Finally when i decided to go go back to the ramp i got real pissed off and said fuck it so i was heading back at around 70 mph and i did not get any water at that speed or my syphon was removing it real good becouse my bilge thru hull pisser did not throw any water out???

  10. #10
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    Put it on the trailer, back it into the water, run it for a few minutes and see where the water is coming from.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 23
    Last Post: 07-21-2015, 05:04 PM
  2. Replies: 0
    Last Post: 03-23-2015, 09:36 AM
  3. Rxpx 2009 carbon seal issues!
    By quiddo15 in forum 4-Tec Performance
    Replies: 0
    Last Post: 10-27-2013, 04:18 AM
  4. 2012 RXPX 260 RS pump shoe seal problem help!
    By stiv in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-20-2013, 10:36 PM
  5. Crbon seal 2012 rxpx
    By eissa in forum 4-Tec Performance
    Replies: 4
    Last Post: 03-16-2012, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •