Results 1 to 3 of 3
  1. #1
    kensmith's Avatar
    Join Date
    Mar 2013
    Location
    TX
    Posts
    1,010
    +1
    13

    Broken pump shaft

    Click image for larger version. 

Name:	IMAG6305.jpg 
Views:	44 
Size:	43.8 KB 
ID:	301492Click image for larger version. 

Name:	IMAG6306.jpg 
Views:	37 
Size:	72.6 KB 
ID:	301493Click image for larger version. 

Name:	IMAG6308.jpg 
Views:	42 
Size:	58.3 KB 
ID:	301494Click image for larger version. 

Name:	IMAG6303.jpg 
Views:	40 
Size:	65.0 KB 
ID:	301495 I'm not sure if this is an alignment issue or debris I don't see any bends though in the impeller just damage from the break. What do you think ? I think I need to get an alignment tool anyways.
    It's got about 25 hrs. on it since I put the pump back together, new bearings & seals , new through hull bushings & seals too


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,525
    +1
    1,270
    likely the shaft should have been replaced, they aren't very expensive and when they run with the bearings destroyed the can get pretty hot ( even when fully submerged in water)

    When I rebuild a kaw or ploaris pump that had bearing failure of the big kind, a new prop shaft is always on the list

    get a good drill and a giant easy out and maybe you can salvage the prop.

  3. #3
    kensmith's Avatar
    Join Date
    Mar 2013
    Location
    TX
    Posts
    1,010
    +1
    13
    no its toast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Broken pump shaft anyone?
    By sunchaser1997 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 07-04-2010, 05:04 AM
  2. Pump Ext Mod: Broken Drive shaft
    By aha in forum 4-Tec Performance
    Replies: 66
    Last Post: 11-26-2008, 02:42 PM
  3. Ever break a pump shaft?
    By Green Hulk in forum 4-Tec Performance
    Replies: 19
    Last Post: 11-20-2006, 05:42 PM
  4. Broken drive shaft
    By Trimer in forum 4-Tec Performance
    Replies: 7
    Last Post: 10-11-2006, 01:09 AM
  5. BROKEN PUMP
    By John in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-11-2006, 05:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •