Results 1 to 7 of 7
  1. #1
    Rende's Avatar
    Join Date
    Aug 2012
    Location
    Toronto Canada
    Posts
    62
    +1
    2

    2003 gtx vans wake edition issue please help

    Hello I have a 2003 gtx 155 vans wake edition sea doo. Yesterday on the water my gas gauge read 2 bars but It was bone dry so I ran out of gas. I Tried to start it several times thinking I still had gas. When I finally got towed back in I started checking it out and found my oil dipstick was bone dry? Then I realized it was out of gas. I filled it back up with gas and topped up the oil as my dipstick was bone dry. Put in about 2 litres. Started it up and kept checking oil and saw there was way to much. Pumped oil out, pretty much same amount I put in. Now after running it for a couple hours i notice more then usual white smoke? I keep checking the oil cause the smoke worries me I'm burning oil plus the fact my dip stick was bone dry. Would trying constantly to start it with no gas cause the oil to burn or cause something else so I wouldn't get a oil reading on dipstick? Seemed to run okay. Started every time and no weird noises. It would run about 48-49mph at 7220 rpm. Is this normal for this ski? I just purchased it. Idles at 1750-1800 rmps. Please any help would be much appreciated


  2. #2
    Rende's Avatar
    Join Date
    Aug 2012
    Location
    Toronto Canada
    Posts
    62
    +1
    2
    Quote Originally Posted by Rende View Post
    Hello I have a 2003 gtx 155 vans wake edition sea doo. Yesterday on the water my gas gauge read 2 bars but It was bone dry so I ran out of gas. I Tried to start it several times thinking I still had gas. When I finally got towed back in I started checking it out and found my oil dipstick was bone dry? Then I realized it was out of gas. I filled it back up with gas and topped up the oil as my dipstick was bone dry. Put in about 2 litres. Started it up and kept checking oil and saw there was way to much. Pumped oil out, pretty much same amount I put in. Now after running it for a couple hours i notice more then usual white smoke? I keep checking the oil cause the smoke worries me I'm burning oil plus the fact my dip stick was bone dry. Would trying constantly to start it with no gas cause the oil to burn or cause something else so I wouldn't get a oil reading on dipstick? Seemed to run okay. Started every time and no weird noises. It would run about 48-49mph at 7220 rpm. Is this normal for this ski? I just purchased it. Idles at 1750-1800 rmps. Please any help would be much appreciated

    Anybody?

  3. #3
    Ski Hacks MG's Avatar
    Join Date
    Apr 2013
    Location
    Georgia
    Posts
    5,253
    +1
    990
    Too much oil can kill your top speed. You need to check the oil with the ski level on a trailer to obtain the most desired level.

  4. #4
    Rende's Avatar
    Join Date
    Aug 2012
    Location
    Toronto Canada
    Posts
    62
    +1
    2
    Quote Originally Posted by CCW View Post
    Too much oil can kill your top speed. You need to check the oil with the ski level on a trailer to obtain the most desired level.
    So 48-49 is not the top speed of that ski??

  5. #5
    wheres the ramp? juanky's Avatar
    Join Date
    Sep 2009
    Location
    coral springs
    Posts
    23
    +1
    2
    no at all i have an 04 wake and i pull 55-57 easy with the ski

  6. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Are you guys looking at a gps speed or looking at the dream o meter on the dash????
    Dream o meter is always 6-9 mph faster than your actually going.

    The newer doos are a lot more precise.

  7. #7
    Rende's Avatar
    Join Date
    Aug 2012
    Location
    Toronto Canada
    Posts
    62
    +1
    2
    Quote Originally Posted by wotxxxsd View Post
    Are you guys looking at a gps speed or looking at the dream o meter on the dash????
    Dream o meter is always 6-9 mph faster than your actually going.

    The newer doos are a lot more precise.
    I was reading it off the speedometer on my dash. And also on the digital screen on my dash

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 seadoo gtx issue, please help me!
    By blee in forum 2-Stroke Performance
    Replies: 1
    Last Post: 06-29-2017, 09:42 PM
  2. Replies: 4
    Last Post: 10-16-2016, 12:15 PM
  3. '04 GTX Limited with issues. Please help!
    By 2kflhr in forum 4-Tec Performance
    Replies: 0
    Last Post: 08-22-2014, 10:23 PM
  4. Please help- 2003 vans wake edition
    By Rende in forum 4-Tec Performance
    Replies: 9
    Last Post: 06-06-2013, 06:27 PM
  5. powervalve issue. please help!
    By jeremy3477 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-21-2008, 07:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •