Results 1 to 3 of 3
  1. #1
    Itowpolarismatrix's Avatar
    Join Date
    Aug 2007
    Saratoga, California, United States

    Hard start rough running

    Just pulled my 03 Seadoo gtx sc out of the garage after months of non use. I took the battery off the tender and installed battery weak so I replaced it. Still would not start. went out the next day and topped off low oil. Then it started but runs like its not firing on all cylinders. Not getting any code any ideas what might be wrong

  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Davison, Mi
    start with good fresh gas and new plugs

  3. #3
    gsxr800's Avatar
    Join Date
    Jan 2008
    Rivershit, Ct
    Quote Originally Posted by skidoochris View Post
    start with good fresh gas and new plugs
    Yup that's a good start. Had mine run like crap from last years plugs that were in there from fogging engine. Ran like poo

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 04 MSX 110 turbo, Hard start and run's away when it does.
    By caliburn in forum Polaris Open Discussion
    Replies: 10
    Last Post: 01-08-2013, 12:53 AM
  2. 98' 1200XL Vibration & Hard Start after Running
    By barkster in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 04-02-2012, 10:00 AM
  3. 2002 Virage TXI won't Start or Runs rough when Damp
    By cjohnson in forum Polaris Open Discussion
    Replies: 16
    Last Post: 07-11-2011, 11:18 PM
  4. 9hrs Hard Start. Runs rough, then OK 10 seconds
    By Kevan in forum Kawasaki PWC Performance (4-stroke)
    Replies: 9
    Last Post: 06-16-2008, 06:22 AM
  5. 96 SLX780 Rough Idle, Hard Start, and Miss
    By rickreeves1 in forum Polaris Open Discussion
    Replies: 23
    Last Post: 02-27-2008, 06:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts