Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    New to GreenHulk! Fuel Injection Problems!!

    I have a 2004 Polaris Genesis i. Its fuel injected. Bought it, ran fine for 2 days straight. Now its not getting enough Volts to the Injectors! If I unplug one of the injectors it starts and runs, if you try with all 3 it just turns over (assuming injectors arent working) and wont start. Have fuel pressure. I read one of the forums and it was saying the battery could be bad. My battery drops to 9 volts while cranking (I read it needed 11+), but I put jumper cables from another battery to the selonoid and grounded it and still nothing. It is getting a connection to the other battery because it turns over faster. Any ideas??


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Have you actually measured the voltage on the White/Red wire, with all injectors plugged in?

    If it is not over 20 volts while cranking, then the EMM power section is probably in need of repair.

    I could be a problem with the flywheel magnets or the stator, but the EMM is the more likely suspect.

  3. #3
    Thanks for the response.
    But yes I have measured the voltage with all 3 plugged in it jumps around only topping out at 11ish. With one unplugged it gets to 18ish and runs.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by SuperAce View Post
    Thanks for the response.
    But yes I have measured the voltage with all 3 plugged in it jumps around only topping out at 11ish. With one unplugged it gets to 18ish and runs.
    Symptoms are typical of a damaged EMM power section.

    See other members recent threads for more info regarding Ficht EMM operation and failure diagnosis, but the usual fix is to send the EMM to DFI Technologies for repair.

  5. #5
    Alright sounds good. Thanks for the help.

  6. #6
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,514
    +1
    1,258
    Quote Originally Posted by SuperAce View Post
    I have a 2004 Polaris Genesis i. Its fuel injected. Bought it, ran fine for 2 days straight. Now its not getting enough Volts to the Injectors! If I unplug one of the injectors it starts and runs, if you try with all 3 it just turns over (assuming injectors arent working) and wont start. Have fuel pressure. I read one of the forums and it was saying the battery could be bad. My battery drops to 9 volts while cranking (I read it needed 11+), but I put jumper cables from another battery to the selonoid and grounded it and still nothing. It is getting a connection to the other battery because it turns over faster. Any ideas??
    the emm is bad. I had a kaw last season..or was it two?..that had an identical problem

    got the emm back, plugged it in and it was all good.

    when you send it..make sure your paperwork indicates the 'unplug and run" problem.

  7. #7
    Ohh okay. So is this something I could fix myself? Or is it definitely a send it of kinda deal. If so who/where should I send it too?

  8. #8

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by SuperAce View Post
    Ohh okay. So is this something I could fix myself? Or is it definitely a send it off kinda deal. If so who/where should I send it too?
    DFI Technologies, contact details via my signature links, in the Ficht section.

  10. #10
    One more thing for y'all to think about. So I just hooked up a good battery, unplugged an injector got it running and then plugged the injector back in and it stayed running with the help of feathering the throttle. Does that clear anything up or point more certainly to the EMM? Also, its to late to contact DFI where Im at but what do their prices look like? Hows it work?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new to greenhulk!
    By BuffBagwell in forum Sea Doo Sport Boats
    Replies: 5
    Last Post: 07-29-2009, 08:48 PM
  2. RXDI Fuel Injection problems. HELP!!!
    By stellarmedia in forum 2-Stroke Performance
    Replies: 2
    Last Post: 05-15-2009, 06:45 AM
  3. Hey Jim new to Greenhulk.
    By emack10 in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 08-30-2007, 08:21 PM
  4. I'm New to GreenHulk...
    By 96gtxdoo in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 11-17-2006, 02:03 PM
  5. Hello, new to Greenhulk
    By FLY6584 in forum Open Discussion
    Replies: 57
    Last Post: 09-11-2006, 05:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •