Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1

    MSX140 rough idle/no idle

    I have a 2003 MSX140. It will not idle but will run if the throttle pulled continuously. I disconnected the TPS and it ran at high speed idle by itself and seemed to run good. Have changed spark plugs and drained old gas. Found two fuel leaks and corrected those as well. Still no solution. I found a TPS online and placed an order for it for kicks and grins. Has anyone out there had this problem and what did you do to fix it?


  2. #2
    update.........now it doesn't start at all. No parts changed at all. Just dead. Plugs are dry and there is a light ticking noise which sounds like the injectors. Sprayed a shot of starting fluid in the intake and it kinda wanted to start. I have no Idea!!!

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Measure injector voltage at the White/Red wire, with all injectors plugged in. While cranking this should be over 20 volts.

    Unplug one injector and see if it starts.

    Also measure fuel pressure while it is cranking. Should be over 20 PSI.

  4. #4

    Update

    Well, I got a new TPS installed. Now it just will not idle.

    I have no connector small enough to put my pressure gauge on the pressure fitting.

    What should I do?

  5. #5

    another update

    checked fuel pressure with a tire gauge and got 20 psi.

    Disconnected each injector (one at a time) and plugged back in while at idle and each made a noticable difference between plugged and unplugged. I would assume that each injector works as a result of that test.

    Definately out of ideas.....

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Quote Originally Posted by [email protected] View Post
    ... Disconnected each injector (one at a time) and plugged back in while at idle and each made a noticable difference between plugged and unplugged. I would assume that each injector works as a result of that test. ...
    Quote Originally Posted by [email protected] View Post
    Well, I got a new TPS installed. Now it just will not idle. ...
    Does it actually idle?

  7. #7

    response

    No it doesn't idle. I have to constantly rev it to keep it going.

    Checked first vacuum line and it was ok. Checked second one and it has a very slight leak. Getting ready to check the third now.

  8. #8
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    does it start on its own or with starting fluid only?

  9. #9

    response

    It will start on its own without starting fluid.

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Quote Originally Posted by [email protected] View Post
    ...

    Checked first vacuum line and it was ok. Checked second one and it has a very slight leak. Getting ready to check the third now.
    What three 'vacuum lines' are you referring to?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rough idle and no throttle response
    By ddrk5436 in forum 2-Stroke Performance
    Replies: 4
    Last Post: 10-30-2013, 09:34 AM
  2. 2002 virage I no/rough idle
    By rhino81 in forum Polaris Open Discussion
    Replies: 41
    Last Post: 06-13-2011, 04:19 PM
  3. 94 650 xp rough idle and flat spots
    By hotrod_sxty8 in forum 2-Stroke Performance
    Replies: 8
    Last Post: 05-20-2007, 11:27 AM
  4. Low Rpm and Rough Idle
    By njgprider in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 10-05-2006, 09:02 PM
  5. rough idle
    By Snoman in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-11-2006, 01:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •