Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19

Thread: t.o.p. valve

  1. #1

    t.o.p. valve

    Ive replaced this 3 times now and am still not able to get my stage 3 rude charger rxp to run right, still getting oil and fuel blowing into the catch can. out of idea's... any suggestions? (that dont involve explosives)


  2. #2
    HOSS's Avatar
    Join Date
    Aug 2005
    Location
    Kenner, LA
    Posts
    4,759
    +1
    29
    yank the head,,stem seals

  3. #3
    ROTAX RACING performance
    Join Date
    Apr 2005
    Location
    sweden
    Posts
    1,462
    +1
    17
    bad piston rings, or

    to cool engine operating temperature (only if you have open loop)

  4. #4
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    first do a compression test and leak down test too if you have access to the tools needed. rings would be my guess as well.

  5. #5

    Join Date
    Jul 2005
    Location
    Miami, fl
    Posts
    223
    I am having the same issue. I get smoke, fuel and gas in the catch can.
    Jet ski running perfect, compression test fine. Ran 81.4mph like that.
    I am clueless also...
    Hec

  6. #6
    EZ Dock of Long Island Shibby1485's Avatar
    Join Date
    May 2005
    Location
    Long Island, NY
    Posts
    9,464
    +1
    4
    Quote Originally Posted by Hecyan View Post
    Ran 81.4mph like that. I am clueless also...Hec
    they always run awesome right before they blow up

  7. #7
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    check your coolant tank, i know this happened to BDNJ when i was riding his and turns out his overflow tank was bad, go figure?? oil was all over the engine compartment...

  8. #8

    Join Date
    Jul 2005
    Location
    Miami, fl
    Posts
    223
    Keep in mind that this happened also with Riva Stage III, Now I have RR computer and Rude Fuel controller and Rude Charger (No changes)
    Thanks

  9. #9
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    Quote Originally Posted by GTXX View Post
    first do a compression test and leak down test too if you have access to the tools needed. rings would be my guess as well.
    I agree!

    Also, make damn sure you don't have a loop in the hose going to the catch can. I like to have the hose go straight up into the side of the catch can.
    Last edited by Green Hulk; 02-28-2007 at 08:10 AM.

  10. #10

    Join Date
    Jul 2005
    Location
    Miami, fl
    Posts
    223
    I was doing some research and the problem might be in the seals of the oil pump. Do not know how many but I am going to check them.. My compression is perfect. Jerry my hose goes to the side of the catch can, should I change it?
    Hec

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Towing ball valve
    By Kinchyle in forum 4-Tec Performance
    Replies: 17
    Last Post: 03-18-2006, 04:47 PM
  2. RIVA SD Supercharger Blow-off Valve Kit an urgent question
    By amirmiz in forum 4-Tec Performance
    Replies: 2
    Last Post: 11-04-2005, 09:25 AM
  3. Torque setting for oil pressure relief valve plug???
    By CRS in forum 4-Tec Performance
    Replies: 4
    Last Post: 08-27-2005, 10:50 PM
  4. Detail Blow of Valve instructions Please
    By TroyRXP15 in forum 4-Tec Performance
    Replies: 16
    Last Post: 08-11-2005, 01:54 PM
  5. blow off valve question
    By TroyRXP15 in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-21-2005, 02:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •