Results 1 to 8 of 8
  1. #1

    Having bad luck with my 1200 STXR need carb diaphram cover now

    Thought I bought a cherry 2004 with 30 hours on it. It ran for awhile, looks almost new on the outside, once I pulled the heads I could see barnacles.

    Somehow a carb diaphram cover got damaged when pulling the engine. Anyone have one laying around for sale?

    Thanks,
    Curt
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	carb.jpg 
Views:	47 
Size:	69.7 KB 
ID:	301817   Click image for larger version. 

Name:	STXR.jpg 
Views:	50 
Size:	81.3 KB 
ID:	301818   Click image for larger version. 

Name:	barnacles.jpeg 
Views:	53 
Size:	197.2 KB 
ID:	301819  


  2. #2
    Self Confessed Day Dreamer toomanytoys's Avatar
    Join Date
    Sep 2008
    Location
    Sydney, Australia
    Posts
    1,932
    +1
    151
    That is nasty. That is probably a good example why you DON'T buy a low hour Jetski.

    Good luck with it, I hope you get back on the water soon.

    Cheers, Mal.

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    I think its time to rebuild...
    Just maybe...
    That's amazing it ran at all...

  4. #4
    Yeah, she's almost back together now. New Kawi crank, top end kit and gasket kit...also swapped out the stock Impeller to a Skat Trak and had Harry at Group K modify the heads. Had the carbs going to Skiworx for rebuild and mods since the ski had flame arresters when I bought it and didn't want to run lean. I then read a few posts and had FedX turn the shipment around and send it right back. Picked up a used stock air box on eBay for $30 and decided to go that route.

    Just need a diaphragm cover now....what model Keikins are those?

  5. #5
    I have one drop me a pm

  6. #6
    1200 stx-r's Avatar
    Join Date
    Jul 2007
    Location
    NWCT
    Posts
    2,517
    +1
    200
    since you rebuilt it did you go with the 1350 big bore kit?

  7. #7
    Quote Originally Posted by 1200 stx-r View Post
    since you rebuilt it did you go with the 1350 big bore kit?
    no, just keeping this one fairly stock...

  8. #8
    1200 stx-r's Avatar
    Join Date
    Jul 2007
    Location
    NWCT
    Posts
    2,517
    +1
    200
    Just as well it already uses gas way too fast !!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hi i think i have a problem with my gph please help need advice
    By liljosemiami in forum Kawasaki PWC Performance (4-stroke)
    Replies: 39
    Last Post: 10-14-2012, 05:38 PM
  2. having a problem with a local dealership...need suggestions
    By gorilla03 in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 04-01-2009, 09:29 PM
  3. I have Ignition Problem With my Sltx Help me!
    By Vortexx972 in forum Polaris Open Discussion
    Replies: 23
    Last Post: 03-03-2008, 02:23 PM
  4. Bad luck with new RXP...
    By GoatnRXP in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 10-16-2007, 04:00 PM
  5. Still have a problem with my RXP.....
    By LiquidDI in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-04-2006, 01:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •