Results 1 to 5 of 5

Thread: speedo

  1. #1

    Join Date
    Mar 2008
    Location
    saskatchewan
    Posts
    152

    speedo

    tried the search could not findany info on removing speedo cable on o4 gpr. was wondering best way to remove it . is it ok to just cut wire right at bak of hull by ride plate or do i have to feed wire through. just wondering if it will screw anything up by cutting wire


  2. #2

    Join Date
    Mar 2008
    Location
    saskatchewan
    Posts
    152
    want to know cause my ride plate is off and was gonna fill in were the paddle wheel goes.

  3. #3
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,326
    +1
    49
    It is easy to just unplug it at the wire connections under the display and feed the wires through the zip ties. the ties are made to loosen they have a release tab.

  4. #4

    Join Date
    Mar 2008
    Location
    saskatchewan
    Posts
    152
    ya i guess i could do it that way . save the wire i guess . i just wanted to make sure that if it wasnt connected that it would not screw something up electrically. well thanks for the reply

  5. #5
    jstanfi1's Avatar
    Join Date
    Apr 2013
    Location
    Lafayette, Indiana
    Posts
    118
    +1
    5
    By far the best thing to do is replace the wire, but if you do decide to cut and splice, make sure you use liquid electrical tape. When properly applied and cured the stuff really is waterproof. I usually take a little alcohol to clean the old wires, twist the wires together, apply a small amount of solder, then do a minimum of 3 coats of the liquid tape for anything like that. I've got installs like that on a variety of other "toys" that have been elements exposed for a decade with no issues.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stock Speedo correct!
    By Pale Rider in forum Sea Doo Open Discussion
    Replies: 14
    Last Post: 06-14-2006, 10:56 PM
  2. Riva Speedo Block off = junk
    By spud in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 11-27-2005, 02:19 AM
  3. Trim tabs and removing stock speedo
    By 01xdime in forum 4-Tec Performance
    Replies: 0
    Last Post: 11-12-2005, 10:13 PM
  4. speedo not working
    By jetskibill9999 in forum 4-Tec Performance
    Replies: 3
    Last Post: 10-09-2005, 06:41 AM
  5. RXP Speedo Questions
    By tchies in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-21-2005, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •