Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1

    Join Date
    May 2013
    Location
    Moore, OK
    Posts
    9

    2008 RXP X leaking at pump...

    was getting the skis ready for the summer and saw this water leak near the pump. It looks like the area where the pump meets the shoe.

    What am I looking at here? Is this a simple seal swap?

    Please advise

    Thanks





  2. #2
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    There is a restrictor washer at that spot that tends to blow the sealer out. The OEM washer comes with sealer applied on it. You can try Ultra Black or Right Stuff, but you are going to have to let it dry for a day or two. Dealer may have the washer in stock and then its just a R and R.

  3. #3

    Join Date
    May 2013
    Location
    Moore, OK
    Posts
    9
    Im going to try the Ultra Black... What exactly is that washer sealing up? when I turned off the hose the water leak went away quickly...

    The ski ran great yesterday otherwise

  4. #4
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    You have to pull the pump. The washer goes between to pump and pumpshoe.

  5. #5

    Join Date
    May 2013
    Location
    Moore, OK
    Posts
    9
    will I have to pull the pump to seal it? I was going to just smear it on the outside where the leak was...

  6. #6
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by beav626 View Post
    will I have to pull the pump to seal it? I was going to just smear it on the outside where the leak was...
    See jp's post above.

  7. #7
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    looks like your washer/restrictor is missing. You are looking for a round green rubber coated washer with a tab sticking up on one side. If you cant see the green tab sticking out, then its not in there, and thats your problem

  8. +1 by:


  9. #8
    DaveC's Avatar
    Join Date
    Jun 2007
    Location
    Central Oklahoma
    Posts
    2,362
    +1
    41
    From the pic I am not able to see the leak. But if it is leaking at the restrictor or at the bilge siphons it should be a easy fix. But yes, you will have to pull the pump. I would be surprised if David's Sport Center has the part in stock.

  10. #9
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    It's definitely the restrictor washer seal that's blown, or the restrictor wasn't put back in the last time the pump was removed (that wouldn't be good for your IC). The only way I can get these to last a decent amount of time is to install them coated in ultra black on both sides. Mine generally always blew out on the bottom though, where the seal is very thin.

    Cheap part... easy fix!

    It appears the top of your seal is missing... the larger tab should be visible with pump installed.

    This is what they look like new...

    Click image for larger version. 

Name:	IMG_20130528_194249_192.jpg 
Views:	52 
Size:	50.7 KB 
ID:	302129

  11. #10
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Quote Originally Posted by BigDaddyRXP View Post
    It's definitely the restrictor washer seal that's blown, or the restrictor wasn't put back in the last time the pump was removed (that wouldn't be good for your IC). The only way I can get these to last a decent amount of time is to install them coated in ultra black on both sides. Mine generally always blew out on the bottom though, where the seal is very thin.

    Cheap part... easy fix!

    It appears the top of your seal is missing... the larger tab should be visible with pump installed.

    This is what they look like new...

    Click image for larger version. 

Name:	IMG_20130528_194249_192.jpg 
Views:	52 
Size:	50.7 KB 
ID:	302129
    Thanks for picture. I was trying to find one in my garage without any luck.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 06-20-2011, 04:49 AM
  2. water leaking through pump at steering cable
    By pbrxp in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-17-2010, 02:48 PM
  3. Replies: 12
    Last Post: 06-30-2009, 07:53 PM
  4. FS: 2008 RXP fuel pump
    By Hydrotoys in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 04-02-2009, 03:31 PM
  5. Water leak at oil pump?????
    By VegasRatt in forum Polaris Open Discussion
    Replies: 8
    Last Post: 07-09-2007, 02:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •