Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1

    Help ultra 150 issue cutting out

    I have 1999 ultra 150 that is bone stock with 115 hours. The ski is cutting out on top end. It acts like it is running out of gas or fire. I rebuilt the carbs hoping to fix it the issue and the ski seemed to run good for a day but the issue returned. It will run hard for a while the start bogging and kick back in. I would appreciate any help you have to offer.


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,009
    +1
    283
    Fuel filter? What happens if you give it a little choke?

  3. #3
    Quote Originally Posted by steve45 View Post
    Fuel filter? What happens if you give it a little choke?
    I have changed the fuel filter. Not sure about the choke but the ski runs fine some times then it will just start cutting back real bad. I can be running wide open and it just cuts out so hard I almost go over the handle bars. What stumps me is the fact that it comes and goes like something is sticking. I guess it could be ignition too.

  4. #4
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,009
    +1
    283
    Check the battery cables to make sure one isn't loose. Try running on Reserve. Run with the seat off and see if you see/hear anything odd. What do the spark plugs look like?

  5. #5
    Quote Originally Posted by steve45 View Post
    Check the battery cables to make sure one isn't loose. Try running on Reserve. Run with the seat off and see if you see/hear anything odd. What do the spark plugs look like?
    battery cables are tight, I have run it with the seat off and it sounds fine, and the spark plugs look similar. The ski has been doing this on and off for a while but it got worse lately. It will run strong then just die out and almost throw you over the handle bars. I don'yt think it is bad gas but i may draina nd clean the tank just for the heck of it. This issue is driving me crazy. I am wondering if it is ignition related.

  6. #6
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,181
    +1
    98
    Could be the fuel pump diaphragm. Mine did what yours is doing, it was that. Sadly, it cannot be bought as a part, you have to replace the entire fuel pump.

    A simple check is to connect a hose to the pulse fitting on the carb and suck, see if its leaking. It should hold a vacuum.

  7. #7
    When the pump diaphragm is bad will it come and go? The ski might run fine for 10 minutes then start acting up.

  8. #8
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,181
    +1
    98
    Quote Originally Posted by kcc0521 View Post
    When the pump diaphragm is bad will it come and go? The ski might run fine for 10 minutes then start acting up.
    Yes. You can remove the fuel pump and disassemble and see if its failed. Just can't fix it sadly.

  9. #9
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,520
    +1
    1,269
    did you use a OEM filter for replacement?, if not put a line splice in there and retest. K's are a bit finicky about the filter issue. paper filters cause problems

  10. #10
    I did not use an oem filter but the fuel filter has been on the ski for a while. Maybe I will try a different filter because I am struggling to determine the problem. Does anyone know wht a bad coil or cdi will do and how to determine if its fuel or electrical?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 01 Ultra 150 Complete Part out
    By joewharton2 in forum Kawasaki Classifieds
    Replies: 17
    Last Post: 08-31-2009, 10:58 PM
  2. ultra 150 issues
    By smartalec_87 in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 07-07-2009, 10:36 PM
  3. Ultra 150 issue
    By coldspace in forum Kawasaki PWC Performance (2-stroke)
    Replies: 3
    Last Post: 03-08-2009, 10:52 AM
  4. Help with major Ultra 150 issue
    By kcc0521 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 10
    Last Post: 09-04-2008, 07:47 AM
  5. need throttle cable help ultra 150
    By chritopherlloyd in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 05-18-2008, 02:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •