Results 1 to 6 of 6
  1. #1

    2002 virage still broke, and going to go broke repairing it

    replaced tps, and then later, replaced fuel pump, starting to get expensive, and wondering if shop I took it to, has the know how? Still runs rough, guy at shop, did find some codes, one was a overheat, ugh, surely the EMM isnt going out? He told me the new plugs (ngk) he put in, were fouling, gonna give him till friday, lol any tips on how to deal with guy, if it isnt purring?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Exactly which part number NGK spark plugs are in it now?

    What is the fuel pressure?

    What is the injector voltage while running?

    What were the codes?

  3. #3
    Only talked with him shortly on phone saturday, will try to get more info today or tomorrow, he did say the compression was good, and will ask him if he got the correct ngk plug, thanks for replying k447, lol getting the bad side of owning a ski right now!

  4. #4
    Well, the ski is running, and its acting like it did last year, not as cold natured, missed some and hesitated, got warm, it ran up to speed, they guy who serviced it, was going out of town, at least he appears to be honest. I didnt want the ski locked up in his shop. So I paid him for the work done on the fuel pump. Noticed riding it today, the speedometer needle would go to 30mph, and stick or not move at all, and when I looked at the digital, it wasnt moving either, noticed it was stuck @ 30 mph, like the needle, churned back end right and left, didnt seem to help, any ideas? They dork that up, when they changed fuel pump?

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Check the clear hose that runs from the pitot under the drive shaft up to the display. My guess is that the hose is pinched or damaged somewhere. The MFI digital speed display and the MFI speedometer needle are driven by the same pressure signal from that clear hose.
    Last edited by K447; 06-02-2013 at 11:40 AM.

  6. #6
    Well, the clear line wasnt pinched, but I crawled under ski, to find a piece f driftwood, perfectly lodged between grate and pitot tube, going back on the water this afternoon! Thanks k447

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Virage problem...a real mystery to me.
    By dalepatter in forum Polaris Open Discussion
    Replies: 29
    Last Post: 07-02-2012, 05:28 PM
  2. 2002 Virage I stalled and will not start
    By dalepatter in forum Polaris Open Discussion
    Replies: 9
    Last Post: 04-29-2011, 01:21 AM
  3. 2002 Virage 700 starts and runs 4 minutes or so then stops, help!
    By 2002 Virage Fan in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-17-2010, 10:43 PM
  4. 2002 virage 700's and Virage TX 1200 For Sale
    By thomslik in forum Polaris Skis
    Replies: 1
    Last Post: 04-25-2009, 09:02 PM
  5. 2002 virage 700's and Virage TX For Sale
    By thomslik in forum Polaris Classifieds
    Replies: 0
    Last Post: 04-22-2009, 03:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •