Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1
    Sinde91's Avatar
    Join Date
    Nov 2009
    Location
    Chicago
    Posts
    68

    Question Freinds RXP shutting down.

    Hi my friend has a modded 2004 rxp yesterday we were cruising & he took a sharp turn & noticed the rpms dropped to only 6000. We then headed to shore & noticed the clamps came off the interecooler. We put them back on & now the ski only runs for about 6-8 seconds & shuts off. Not sure were to start or what to even look for. It has the rotax racing ecu, x charger, fizzle inter cooler, r & d intake. It has more but I can not remember off the top of my head. Any suggestions or advice would be great thanks.


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    now the ski only runs for about 6-8 seconds & shuts off
    @ Idle, or during WOT?

    Sounds like blockage in the IC, or water leaking internally..

    Also check the SC for touchdown, and the bearings

  3. #3
    Sinde91's Avatar
    Join Date
    Nov 2009
    Location
    Chicago
    Posts
    68
    Yes at idle, also what is WOT? Sorry still a little new to the water craft terms. He did also look at the super charger & said it was a little loose. Thanks psycho

  4. #4
    mattydipps's Avatar
    Join Date
    Mar 2013
    Location
    Babylon, Long Island
    Posts
    652
    +1
    51
    Quote Originally Posted by Sinde91 View Post
    Yes at idle, also what is WOT? Sorry still a little new to the water craft terms. He did also look at the super charger & said it was a little loose. Thanks psycho
    wot = wide open throttle... aka full throttle..

    the supercharger isnt supposed to spin freely.. if it does i would pull to inspect and most likely rebuild

  5. #5
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Quote Originally Posted by Sinde91 View Post
    Yes at idle, also what is WOT? Sorry still a little new to the water craft terms. He did also look at the super charger & said it was a little loose. Thanks psycho
    How many hours has it been since his last SC rebuild ? Pull the intake tube off the SC, and see if he can spin the blades by hand freely. If so, then the Charger is toast. Which would need to be pulled to check bearings, and see what's left.

    If that checks out, run it on the hose, and pull the Tube/ coupler off at the throttle body, and see it it spits water when u rev it up. Check spark plugs, and report back all findings.

  6. #6
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Where in Chicago area are you?

  7. #7
    Sinde91's Avatar
    Join Date
    Nov 2009
    Location
    Chicago
    Posts
    68
    He is from Niles, I am in Lansing south of Chicago.

  8. #8
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    I'm in Crest Hill, near Joliet...if you need any help, send me a PM. I'll be home all weekend, I'm building a ski for someone right now...Will be trying to head to the water this weekend, in Wilmington...Where do you ride? Where did this issue occur?


  9. #9
    Sinde91's Avatar
    Join Date
    Nov 2009
    Location
    Chicago
    Posts
    68
    Ok I am reporting back with what we have done.
    Checked inside the intercooler, nothing in it.
    Checked to see if water spits out of the throttle body & it doesn't.
    The supercharger wheel doesn't spin with trying to push it with your finger.
    Changed spark plugs, & just for the hell of it drained the gas tank & put some BP gas in it (the other gas was 2 weeks old).
    Did take the hose off the throttle body to have it run & it was running the day before, now it just dies out withing about 5 seconds.
    We are really lost & not a clue what could be going on.....

  10. #10
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,445
    +1
    182
    Does he have a rising rate Fuel Pressure regulator?, and if so what is his fuel pressure set at with the key on, engine off?

    What size injectors is he running?
    Does he have an AFR guage?

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 07 RXP randomly shuts down, no anything.. Help!
    By RXPteamtimebomb in forum 4-Tec Performance
    Replies: 10
    Last Post: 10-05-2014, 06:58 PM
  2. 05 rxp shut down CHECK ENG LIGHT ON help please!
    By scartigue in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-31-2011, 05:14 AM
  3. GP 1300 Overheating / Shutting down
    By Polarisracer166 in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 07-25-2007, 11:30 AM
  4. Shut down my town
    By Pettee in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-25-2006, 10:32 PM
  5. Dreams of RXP=shot down..
    By wakeborder556 in forum Sea Doo Open Discussion
    Replies: 26
    Last Post: 01-15-2006, 09:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •